Jump to content
Corsair Community

RMA not answering - Brazil


Karore
 Share

Recommended Posts

Hello,

 

I know this is not the brazilian forum, but the brazilian webpage redirects me to this forum, so I'm here to ask for some help.

 

I have been trying to contact Corsair since january 18th but have not had a single reply from them yet. I had purchased a TX 650W PSU that malfunctioned after about 3 or 4 months that it was installed and I need to RMA it.

 

On january 18th I opened a RMA request in the brazilian RMA system (ticket 41747) and have not had a single reply to it. When I try to reset my password to access the RMA system, I never receive the e-mail to reset it and I did try it quite a few times over the last month (also checked spam, filter rules etc).

 

I have also tried the "Contact us" form on the Corsair page, but got no reply so far. I also searched and found a phone number on google and tried calling it, but the line is always busy.

 

I am quite out of options right now and would like to at least get some answers regarding this process.

 

Thank you very much for any help you can provide.

Link to comment
Share on other sites

Hello Technobeard,

 

Thank you very much for your attention.

 

When I go to the brazilian web page, if I mouse over "Comunidade" (community) and then click on "Fórum" (forums) it takes me straight to this user forum (as you can see on the shortcut shown at the bottom of the image.

 

Also, I did try the options I had at the support tab right beside the community tab, but could not get in touch with the brazilian support team :[pouts:

 

Once again, I thank you kindly for your assistance in this matter.

1976315185_Forumlink.thumb.png.f536a79ecd6097bb4f445d19da281742.png

Link to comment
Share on other sites

 Share

×
×
  • Create New...