Jump to content
Corsair Community

HS60 Pro, usb 7.1 sound adapter not recognize by Windows


Recommended Posts

Guys, need a emergency help!

I bought this headset maybe 5 month ago and since that I had problem with Windows.

I always used the sound adaptor because my mother board do not have a P3 entrace.

Always my device get disconnected for no reason, so I had to put it again to work.

 

So yesterday, the problem happened, but not worked when I put it again.

I got that error: "USB device not recognized device descriptor request failed code 43"

 

So I tested the headset in a Phone and its working very well.

I formated the windows to see if that will solve my problem and didnt worked.

 

Please someone help. I need that to work every day ;-;

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...