Jump to content
Corsair Community

Virtuoso reset/mode switch causing discord distruption


SniperJesus
 Share

Recommended Posts

I am currently encountering an issue triggered by the AMD x570 USB dropout mostly but due to that I found a bug in the way iCUE/Discord interacts at least on windows 10 pro.

 

When the USB dropout occurs, or I switch between wired and wireless modes, I have issues with discord inbound voice channel audio. I can't hear anything from anyone in the voice channel but they can all still hear me until I leave the channel and rejoin or sometimes have to restart both iCUE and discord. When this happens I still hear all application sounds from discord such as the bings for entering and leaving channels and all my other system sounds still function. The issue triggers at the exact moment iCUE reconnects to the headset. For example, when using the headset in wireless mode I can be in a voice channel and talking fine, I switch to wired mode and everything continues to work for a few seconds on the windows driver until iCUE reconnects and I hear the "Mic Muted" or "Mic On" sounds from the voice prompt. The instant this happens I lose all output coming from the voice channel. If I do not have iCUE running I never see an issue but then I dont get the 7.1 surround mode. Normally I would just deal with it as mode changes are rare but in combination with the ongoing x570 issue it happens very often and is very very frustrating. I can either have 7.1 and the annoying green light on my mic turned off or I can have stable communication with my friends/squad.

 

To make things more interesting, I am unable to reproduce this issue on a machine with the same headset, icue, and discord versions that is running windows 10 home 1909. (Intel x99 chipset). Another thing to note is on the windows 10 home computer the system tray icon for iCUE is RGB and full color. On my Windows 10 Pro machine, the system tray icon is black and white. Have no idea what is going on with that.

 

 

Things I have tried:

1) The solution detailed in the issue for windows patch 1903

2) full clean installs of both iCUE and Discord

3) Running iCUE as admin

4) Running discord as admin

5) Running discord in compatibility mode for both windows 7 and 8 (both with and without admin elevation)

 

I have never had a different icue version on this pc or discord version as I rebuilt/reinstalled within the last week. There are very few things on my system right now. Any help/tips anyone could give would be greatly appreciated.

 

iCUE Verison: 3.37.140

discord version Stable 77192

Windows: Windows 10 Pro 20H2

Link to comment
Share on other sites

 Share

×
×
  • Create New...