Jump to content
Corsair Community

M55 Requires firmware update or reconnect after every reboot


Recommended Posts

Hello,

Every time after startup and iCUE start the dpi and side buttons aren't working. iCUE says that firmware update is required and after it's done everything is back to normal, also reconnecting the mouse works too. Maybe there is an option to do firmware update automatically after iCUE start, so I don't have do to it or reconnect the device each time I boot.

If i leave the mouse in the locked state, turn off iCUE autostart and reboot, then the mouse still doesn't work properly. If I leave it working fine and reboot without launching iCUE the mouse is working fine also. Only when iCUE is launched the mouse stops working right, and it doesn't work until I reconnect it or update firmware, despite reboots or having iCUE off.

Corsair composite virtual imput device is always on.

Is there a way to copy my settings to mouse hardware, I'm only having right side buttons work same as left side buttons, if that was a possibility then I wouldn't need to start iCUE at all. Or have the side buttons be mirrored by default in next firmware update, if possible.

Also I noticed that it happens during FIRST iCUE launch after a boot - either automatic or manual. If i turn iCUE off and turn it again it doesn't turn off the buttons the second time

The system is a fresh install of Windows 20h2 with all updates done

Edited by deadzior
Link to comment
Share on other sites

I will paste here the content of the ticket, maybe some people encounter the same issue. For me it seems like iCUE issue, so I don't think swapping the mouse will help, but who knows

 

 

When system is booted with mouse connected, launching iCUE causes the mouse side and dpi buttons to stop working (the dpi is locked to the one that was during iCUE launch). iCUE says that a firmware update is required. The problem is resolved by updating firmware or replugging the mouse (so firmware update is in fact not required, it always updates to the same version anyways). After rebooting the system the issue comes back - when iCUE launches the buttons lock up and I get the firmware message. If iCUE is not being launched the mouse works on default hardware settings without issue. If the problem occurs, turning off iCUE doesn't help, only update or replugging fix it. Launching iCUE for the second time during the same boot doesn't cause the issue again - it only occurs once after each reboot. If I boot with the mouse disconnected, launch iCUE, and then connect the mouse it works fine. Just the process of launching iCUE with mouse connected "breaks" it.

The result of this issue is that if I have iCUE on autostart or in general want to benefit from settings that I set up, I have to press firmware update (which sometimes carries a risk of bricking the device) or replug (which may be tedious) the mouse each time I start my computer.

The Corsair composite virtual input device in devmgmt is always on during this.

Link to comment
Share on other sites

  • 3 weeks later...

I have the same problem after every reboot. I need to unplug and plug the mouse or update it again. Otherwise, the DPI button and side buttons will not work.

 

I contacted the Corsair support team. They told me to uninstall the icue software completely and do a clean install first. However, it didn't work. Then they suggested that I reset the mouse using mouse button combinations. However, that didn't work either. Finally, they offered to send back the mouse and replace it. But this is a huge waste of time and I really don't want that right now.

 

This issue cannot be fixed by any updates?

Edited by Gaspetus
Link to comment
Share on other sites

  • 2 months later...

I had the same problem and fixed it with help from Corsair support. I will attach the important reply from them and also further steps to make sure it works.

 

CORSAIR REPLY:

 

Reinstalling the firmware of your device may correct the issue. We suggest doing this manually, and have uploaded the firmware for your device to the ticket in order to do so. Please follow the directions below:

 

1: Unplug your mouse from the computer.

2: Locate the small pinhole underneath your mouse. For some, this will be located directly on the bottom in plain sight. On others, it will be located underneath one of the removable weights attached to the bottom of the mouse.

3: Using a small paperclip or push-pin, press down on the button inside the pinhole.

4: Plug your mouse back into the computer, while holding down the pinhole button.

5: Once it is plugged back in, your computer should recognize a drive called CRP_Disabled. Please open this.

6: Download the firmware file from the ticket. If it is compressed into a .RAR file, please extract this file to an easily found location on the computer.

7: Delete the file FIRMWARE.BIN from the CRP_DISABLED drive, and then place the file with ISP in it’s name to the CRP_Disabled drive.

8: Once you have performed the steps above, please unplug your mouse and then plug it back in. The device will then return to normal. Please test to see if the issue reappears. If it does, please inform us on the ticket for further troubleshooting.

 

 

I have the file if anyone needs it, just email me at bznicely@gmail.com

 

FURTHER STEPS:

I downgraded from iCUE 4.11.274 to iCUE 3.38.61, which was specified as the proper iCUE for the M55 RGB Pro on the Corsair downloads page and it seems like the problem has been fixed. I updated the mouse firmware to 4.7.23 once and restarted my PC and I didn’t have to update it again after reboot.

 

So it seems like iCUE 4 might have something weird going on with the M55.

 

UPDATE (06 - 06 - 2021):

Corsair Ticket assistants confirmed that iCUE 4 is not compatible with all Corsair products so just downgrade your software and that will help a lot of issues.

Edited by BonganiZulu
New information on problem
Link to comment
Share on other sites

  • 6 months later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...