Jump to content
Corsair Community

Struggling with iCUE integration


clkd
 Share

Recommended Posts

Hi guys,

 

I have just finished my new build that has quite a few RGB components and I have tried my best to make it all iCUE compatible. So, I have an h150i Capellix, 6x QL120's, 4x Vengeance RGB, 4x Corsair RGB strips, Lian Li Strimer Plus VGA + MBO - all connected through Commander PRO, Lighting node, and the AIO Commander. I also have an ASUS x570 STRIX and ASUS RTX3070 STRIX. Everything corsair works great in iCue (except the ML's RGB only works when set up as SL PRO, but that is no big deal) but I am struggling (like many others) with the ASUS part.

The best I have managed to get is everything showing in iCUE, and everything working, including the RTX3070, however, the MOBO RGB I have yet to get to work from iCUE (it shows up, I can change light settings for it but nothing happens). I have tried with Armory Crate, I have tried with AURA Sync 1.07.79_V2.2 with mixed results. Sometimes nothing shows, sometimes red triangle on RAM, sometimes only GFX card is shown in iCUE... The best results seem to be with Armory crate (as stated above, everything showing up and working except the MOBO showing but not working).

I have tried a few things, including removing stuff from program data after installing ASUS software.

 

My question is, is there someone with both MOBO and GPU syncing properly with iCUE, and if so can you give some advice on what you did?

 

Secondly, since the MOBO only seems to show up with Armory crate but, not with Aura Sync, I have tried copying the steps on removing unnecessary program data from a post relating to Aura sync but I can't get it perfectly right on what exactly to remove (I keep breaking Armory crate and nothing shows up in iCUE). Does anyone know how to install Armory crate and disable everything that is not essential for iCUE, including startup stuff, scheduled tasks, and anything I might be missing?

 

I have read a lot about this on the forum but I apologize if there is something simple I have missed. Any advice is appreciated!!!

Link to comment
Share on other sites

The ML-Elite (8 LEDs) that comes with the Capellix Elite coolers should be designated as SP-Pro/SP-Elite/ML-Elite. Those are all 8 LED center hub fans, different from the ML-RGB which is only 4 center hub LEDs.

 

I think you are going to be stuck with Armory Crate on newer MBs and I would expect on the new 3000 series GPUs as well. Asus has ended Aura development some time ago and is forcing Armory Crate on new devices.

 

I can't say on the plugin as I don't have an Asus X570. Perhaps other owners can share whether it is currently working or any other complications. You can try setting AC into one it's basic hardware modes (static, breathing, or color cycle). Those all should be native to the device. I have seen it get stuck between software programs when using more complex Aura/AC effects, and then attempting to override it with CUE effects.

Link to comment
Share on other sites

The ML-Elite (8 LEDs) that comes with the Capellix Elite coolers should be designated as SP-Pro/SP-Elite/ML-Elite. Those are all 8 LED center hub fans, different from the ML-RGB which is only 4 center hub LEDs.

 

I think you are going to be stuck with Armory Crate on newer MBs and I would expect on the new 3000 series GPUs as well. Asus has ended Aura development some time ago and is forcing Armory Crate on new devices.

 

I can't say on the plugin as I don't have an Asus X570. Perhaps other owners can share whether it is currently working or any other complications. You can try setting AC into one it's basic hardware modes (static, breathing, or color cycle). Those all should be native to the device. I have seen it get stuck between software programs when using more complex Aura/AC effects, and then attempting to override it with CUE effects.

 

Thanks for clearing up the ML Elite thing. Was confused since it only says SP Elite in iCUE...

 

I got the RTX3000 working so I am still hoping I can get the MOBO to cooperate one way or the other. I have invested a lot of money and time waiting for specific components to have everything iCUE compatible.

 

Hope someone here has some idea on what my next step should be.

Link to comment
Share on other sites

I have same problem, when I install Armoury Crate no only I can't control MB LEDs from iCue but my RAM also gets a red triangle as I think Armoury Crate controls it. I tried using discontinued Aura Sync and it did not help. Funny thing is that I did initially work when I got this MB a while ago and just stopped after a while :(
Link to comment
Share on other sites

I have same problem, when I install Armoury Crate no only I can't control MB LEDs from iCue but my RAM also gets a red triangle as I think Armoury Crate controls it. I tried using discontinued Aura Sync and it did not help. Funny thing is that I did initially work when I got this MB a while ago and just stopped after a while :(

 

I'll keep trying and playing with different combinations of software and settings next few days and also hope we maybe get an update to either icue or asus.... Ill post back if I figure something out and there is also a chance someone out here already has something figureded out.

Link to comment
Share on other sites

  • Corsair Employees
The Armoury Crate installer pulls the most recent files from their servers and installs them. There is no way to install a previous version. To resolve the issue of the latest Armoury Crate build breaking compatibility with the Asus provided plugin you will need to utilize the Armoury Crate Uninstaller Tool available from Asus, and then download and install the stand alone AURA Sync installer in order to enable your motherboard RGB integration in iCUE.
Link to comment
Share on other sites

The Armoury Crate installer pulls the most recent files from their servers and installs them. There is no way to install a previous version. To resolve the issue of the latest Armoury Crate build breaking compatibility with the Asus provided plugin you will need to utilize the Armoury Crate Uninstaller Tool available from Asus, and then download and install the stand alone AURA Sync installer in order to enable your motherboard RGB integration in iCUE.

 

I have used the uninstall toold multiple times. Few hours ago I uninstalled Armoury Crate and installed Lighting_Control_1.07.79_V2.2 (using AsusSetup.exe). This gave me working MOBO in icue + everything Corsair working, however RTX3070 is now not showing up at all.

 

What exactly do you mean by "stand alone AURA Sync installer"? is this the one I most recently used, or is there something more similar to the ArmouryCrateInstaller I can download somewhere?

Link to comment
Share on other sites

  • Corsair Employees
I have used the uninstall toold multiple times. Few hours ago I uninstalled Armoury Crate and installed Lighting_Control_1.07.79_V2.2 (using AsusSetup.exe). This gave me working MOBO in icue + everything Corsair working, however RTX3070 is now not showing up at all.

 

What exactly do you mean by "stand alone AURA Sync installer"? is this the one I most recently used, or is there something more similar to the ArmouryCrateInstaller I can download somewhere?

 

Have you checked with Asus to see if the 30-series GPU's are compatible with the older Aura Sync? I am not sure but I do not believe that is the case. If you have a 30-series GPU from Asus then you will need to use Amoury Crate most likely. At the same time this would mean you will have to choose one or the other in terms of software as you will not be able to utilize iCUE at the same time as Armoury Crate. Until Asus patches the issue by either providing us with an updated plugin or by patching Armoury Crate this will not be resolved.

Link to comment
Share on other sites

Have you checked with Asus to see if the 30-series GPU's are compatible with the older Aura Sync? I am not sure but I do not believe that is the case. If you have a 30-series GPU from Asus then you will need to use Amoury Crate most likely. At the same time this would mean you will have to choose one or the other in terms of software as you will not be able to utilize iCUE at the same time as Armoury Crate. Until Asus patches the issue by either providing us with an updated plugin or by patching Armoury Crate this will not be resolved.

 

No, I haven't been in contact with ASUS yet because I am pretty certain I will get a generic response from them. But MOBO works with Aura Sync, GPU works with Armoury crate, so the issue must be relatively easily solvable with a bit of developer effort, or maybe even some luck when playing around with different software setups on our side...

Link to comment
Share on other sites

  • Corsair Employees
No, I haven't been in contact with ASUS yet because I am pretty certain I will get a generic response from them. But MOBO works with Aura Sync, GPU works with Armoury crate, so the issue must be relatively easily solvable with a bit of developer effort, or maybe even some luck when playing around with different software setups on our side...

 

I can tell you that I spent several hours of my day last week testing on my personal system with Armoury Crate and trying to find a work around to allow the latest build to still be installed and allow for iCUE control. Unfortunately there is no way to make it work. At this time the only work around is to utilize the older AURA build to allow for iCUE control but you will most likely lose control over your 30-series GPU.

 

You won't be able to have the older AURA and Armoury Crate software installed at the same time because Armoury Crate takes its place when installed.

Link to comment
Share on other sites

I can tell you that I spent several hours of my day last week testing on my personal system with Armoury Crate and trying to find a work around to allow the latest build to still be installed and allow for iCUE control. Unfortunately there is no way to make it work. At this time the only work around is to utilize the older AURA build to allow for iCUE control but you will most likely lose control over your 30-series GPU.

 

You won't be able to have the older AURA and Armoury Crate software installed at the same time because Armoury Crate takes its place when installed.

 

I've sent an email to ASUS, see if they have something to say. Probably nothing useful..

Link to comment
Share on other sites

Just like to add my ASUS Crosshair VIII Impact has recently stopped responding to iCUE for me still shows up as a device though ("ASUS Motherboard"). One whole windows reinstall later I find this thread, ah well...

 

Feel your pain. Good thing Asus responded to my question with a fix you surely did not try yet:

 

"Regarding the described problem, we kindly invite you to Unistall and Re-install again the Armory Crate with "Armoury Crate Uninstall Tool" that you can find it in the below link.

 

 

https://rog.asus.com/motherboards/rog-strix/rog-strix-x570-e-gaming-model/helpdesk_download

 

 

Should you have any further questions, please do not hesitate to get back in touch with us."

Link to comment
Share on other sites

Feel your pain. Good thing Asus responded to my question with a fix you surely did not try yet:

 

"Regarding the described problem, we kindly invite you to Unistall and Re-install again the Armory Crate with "Armoury Crate Uninstall Tool" that you can find it in the below link.

 

 

https://rog.asus.com/motherboards/rog-strix/rog-strix-x570-e-gaming-model/helpdesk_download

 

 

Should you have any further questions, please do not hesitate to get back in touch with us."

Reinstalled armoury crate multiple times, iCUE multiple times, windows from UEFI via USB.

 

No change, Only thing that works is uninstalling armoury crate and installing legacy aura sync. BUT.... That for some reason breaks my Vengeance pro RGB.

Link to comment
Share on other sites

  • Corsair Employees
Reinstalled armoury crate multiple times, iCUE multiple times, windows from UEFI via USB.

 

No change, Only thing that works is uninstalling armoury crate and installing legacy aura sync. BUT.... That for some reason breaks my Vengeance pro RGB.

 

Once you have it installed you will need to make sure it is not set to start when your system first boots into Windows and isn't running when you are attempting to use iCUE. Both will be trying to control the memory and will cause a conflict if attempting to utilize both iCUE and AURA at the same time. Aura needs to be installed for the Asus plugin to communicate with their lighting service in order to control the motherboard RGB but should not be ran other than an initial setup if you wish to set a specific hardware lighting profile for your motherboard, because iCUE does not control those settings of the motherboard.

Link to comment
Share on other sites

Reinstalled armoury crate multiple times, iCUE multiple times, windows from UEFI via USB.

 

No change, Only thing that works is uninstalling armoury crate and installing legacy aura sync. BUT.... That for some reason breaks my Vengeance pro RGB.

 

What Notepad said is correct. I would also like to add that the only thing that worked without the issue coming back is deleting the corsair rgb plugin in Program Data. There is a post by Notepad somewhere that explains this nicely

Link to comment
Share on other sites

At the end it's all ARGB. I'm controlling my Phanteks P500A DRGB LED strip from iCue just by using a custom cable that plugs into Core controller LED socket. I wish that all this RGB ecosystem vendor lock bull**** end but sadly it's always profits above users.
Link to comment
Share on other sites

At the end it's all ARGB. I'm controlling my Phanteks P500A DRGB LED strip from iCue just by using a custom cable that plugs into Core controller LED socket. I wish that all this RGB ecosystem vendor lock bull**** end but sadly it's always profits above users.

 

Yeah I converted all my EK stuff to MX2.54 Dupont connectors by re-terminating them for this reason. No way to do that with the MOBO LEDs though :/

Link to comment
Share on other sites

Any news on this being fixed? I shouldn't be expected to run an outdated version of software to regain compatibility. It works but takes approx 2 mins after startup before the board is recognised and will not launch to let me configure hardware lighting. So to ensure I don't have lights on in the middle of the night I am forced to use armoury crate (no the bios option 'Stealth mode' doesn't work, It's constantly overridden by Aura and I can't open it to change that). Not only this but half the time one or both of my DIMMs will be incorrect due to the conflict and I don't have Aura to start with windows. It was working completely fine no more than 1 month ago.

 

I've lost count of how many times I've reinstalled windows.

Specs: 5950x / 3090 FTW3 Ultra / NVME Gen4 RAID0 Storage / Crosshair VIII Impact

(So it's not my specs)

 

On another note when is 'Corsair.Service' going to be fixed so that any time I move my mouse in game when set to anything over 500Hz I don't lose 10 - 15 fps?

Link to comment
Share on other sites

  • Corsair Employees
Any news on this being fixed? I shouldn't be expected to run an outdated version of software to regain compatibility. It works but takes approx 2 mins after startup before the board is recognised and will not launch to let me configure hardware lighting. So to ensure I don't have lights on in the middle of the night I am forced to use armoury crate (no the bios option 'Stealth mode' doesn't work, It's constantly overridden by Aura and I can't open it to change that). Not only this but half the time one or both of my DIMMs will be incorrect due to the conflict and I don't have Aura to start with windows. It was working completely fine no more than 1 month ago.

 

I've lost count of how many times I've reinstalled windows.

Specs: 5950x / 3090 FTW3 Ultra / NVME Gen4 RAID0 Storage / Crosshair VIII Impact

(So it's not my specs)

 

On another note when is 'Corsair.Service' going to be fixed so that any time I move my mouse in game when set to anything over 500Hz I don't lose 10 - 15 fps?

 

The fix is going to have to come from Asus in the end as iCUE connects to motherboard and GPU RGB via the Asus provided plugin. It is this plugin that Asus broke compatibility with when they released their current build of Armoury Crate.

Link to comment
Share on other sites

 Share

×
×
  • Create New...