Jump to content
Corsair Community

K60 Shows up in iCUE but not edited/updated by it


manicdan
 Share

Recommended Posts

I already have iCUE for other devices and picked up a K60 PRO SE. The moment I plug it in iCUE picks it up, but no changes to the keyboard actually take effect, the keyboard is just in the default color profile determined in Hardware Lighting. Restarting iCUE fixes it, but re-plugging in the keyboard does not and will actually re-break the link. I tried resetting the keyboard and telling the iCUE services to start on a delayed startup, but neither have fixed it.

 

Here's where it gets weirder, only RGB seems affected. I set up actions and they only trigger when I press them on this keyboard (setting a profile switcher for example will only switch if I press page-up on the K60, not any other keyboard I might have plugged in)

 

Software and firmware are all up to date.

 

Appreciate any help, otherwise I am thinking its defective or returning it for something else.

Link to comment
Share on other sites

 Share

×
×
  • Create New...