Jump to content
Corsair Community

Dark Core Pro firmware 2.7.37 has broken wireless mode.


Recommended Posts

OK I think I may have originally corrupted the firmware. Forcing the update this time with the mouse wired directly to the PC and the wireless dongle in the keyboard passthrough allowed both the mouse and dongle firmware to update simultaneously and successfully pair the wireless.
Link to comment
Share on other sites

Make sure both the cable and wireless dongle are plugged in. The firmware needs to update both. I presume mine corrupted because the wireless dongle was missing.

 

 

With the other users having the same issue i do not think you are responsible.

Link to comment
Share on other sites

No obviously it is catching everyone out. I have provided what should be the solution to the issue.

 

This is the normal procedure for an update and others I have directly talked to in discord are having the same issue and updated the recommended way (everything plugged in directly to pc preferably front ports) with mouse directly plugged via usb c.

 

It’s not this simple. This update tonight caused a lot of issues. I managed to revert mine by using an older version of icue then factory resetting the mouse.

Link to comment
Share on other sites

This is the normal procedure for an update and others I have directly talked to in discord are having the same issue and updated the recommended way (everything plugged in directly to pc preferably front ports) with mouse directly plugged via usb c.

 

It’s not this simple. This update tonight caused a lot of issues. I managed to revert mine by using an older version of icue then factory resetting the mouse.

 

Are you sure forcing the update with both the dongle and cable plugged in doesn't work? Mine successfully updated when both the dongle and cable were present.

Link to comment
Share on other sites

When i updated, only the mouse did update firmware and it works as usuall...no problems. Have tested both with wire and wireless, works fine as before firmware update.

 

EDIT: moved my dongle to the frontpanel(i have it in my ST100) and now there was an new firmware to the dongle, updated and it works fine, moved it back to my ST100 and works fine as before update.

Edited by Krokarn
More info
Link to comment
Share on other sites

As posted in another thread: I got the firmware updated succesfully for my Dark Core Rgb SE and also K57 wireless keyboard that came through later. Now if my pc is waking from sleep it's hit and miss whether the wireless mouse will work.

 

It's really weird, the mouse will always wake the pc from sleep but sometimes it wont be working when I've logged into windows. The only way to fix it is to unplug and then reconnect the dongle.

 

Damn Corsair! Why do they always break things that dont need fixing!!!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...