Jump to content
Corsair Community

HS70 Wireless only works plugged in


Recommended Posts

I've been using my HS70 Carbon Wireless for a whole year without any problems, but since a couple days ago my headset only works while plugged into a USB port. As soon as I unplug the cord, it completely dies and can only be turned on again while connected on USB from my PC.

 

I already replaced the usb cord I used to charge it and already tried the soft reset explained from the link bellow, but it still doesn't turn on on wireless mode:

 

https://help.corsair.com/hc/en-us/articles/360037566611-How-to-Reset-an-HS70-Wireless-Gaming-Headset

 

I already tried forcing the firmware update but the problem persists. I'm using Windows 10 Pro 20H2 64bits, my ICUE version is 3.37.140 and the firmware is v 0.64

 

What else can I try to do?

 

Edit: I forgot to mention ICUE either show my headset not connected or with 100% charged battery. I also already tried letting it charge by itself, it shows the red led, but it still seems it didn't charge the headset at all, even though the software is showing that it has 100% charge.

Edited by Flavioedurc
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...