Jump to content
Corsair Community

Scimitar lighting stuck on default


Recommended Posts

For a few years running, I have been using the same scimitar mouse (not the new pro version, I have the black/yellow scimitar) with the same lighting/macro profiles without issue. However, on a recently newly-built pc with the latest version of iCUE and firmware for the scimitar, the lighting can't be changed from the default red (macros still work fine though and setting the rgb color indicator for the different dpi profiles works fine as normal).

 

Here's what I'm doing:

With the mouse/Scimitar selected, under "Lighting Effects" I click the plus symbol to add a new lighting scheme and the default RAINBOW lighting effect gets populated in the list. Nothing changes with the lighting on the mouse (but I'm not concerned because I don't think the scimitar supports all the crazy lighting possibilities).

But even when I go into the lighting effect to change the kind of effect (have tried them all, static/solid/shift...) the mouse still doesn't reflect any changes with the lighting on any of the zones.

 

Here's what I have tried:

- Restarting my pc

- Re-updating the firmware on the scimitar

- Uninstalling/re-installing iCUE

- Deleting the "Default" profile and using a new/different one

- All possible lighting effects with the zones

 

I saw a number of other posts on this forum about same/similar issues, and have tried the proposed solutions I could find, but I still am not able to adjust the lighting within iCUE.

 

iCUE software version 3.37.140

Scimitar firmware version v3.04

 

I think the issue is that the latest, newest, most up-to-date version of iCUE doesn't take into account or play well with legacy devices like the older scimitar. When I close out iCUE, the color scheme returns to the way I had it before/the way I like, but then of course the macros don't work without the software driving them.

 

Would anyone familiar with the topic happen to have a solution for me to try?

 

 

Edit:

 

Between yesterday today, the mouse/software was still not quite right, but I had fully shutdown my pc for the night. Upon booting and logging into my windows/user account, iCUE by some stroke of luck was finally able to talk to the mouse about its lighting, so... problem solved (somehow).

Edited by afitd
Problem Fixed
Link to comment
Share on other sites

  • 2 weeks later...
  • Corsair Employees

Hey afitd,

 

This is very likely due to a software conflict with iCUE.

 

If this happens again, try disabling all RGB control and hardware monitoring/control apps other than iCUE (Such as RGB Fusion, MSI Mystic Light, MSI Afterburner, Wallpaper Engine are a few common suspects) and restarting the iCUE service.

 

Ultimately if this happens repeatedly, please open a ticket with our tech support team for the most direct assistance with this issue.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...