Jump to content
Corsair Community

Recommended Posts

So apparently my K57 is not charging anymore. Battery LED is off when connected, and blinking purple when not plugged in. Tried the ESC key reset thing, had no effect. Should I get a replacement?

 

Firmware 1.1.164.

 

I would've tried an older firmware but I can't find them anywhere.

Link to comment
Share on other sites

It is not available on Amazon right now. On corsair support they told me it may be an iCUE issue, but looks like a firmware issue actually, the battery LED does not blink green when charging, it's actually off all the time (pink when working in wireless mode).

 

Any ideas? Where can I get an older firmware to try? Can I downgrade the keyboard?

Link to comment
Share on other sites

  • 1 month later...

I'm resurrecting this thread to tell you guys that the keyboard was apparently faulty and this bug had nothing to do with any firmware. I finally managed to get a replacement and I have my battery LED indicator again :)

 

Just one question though, what's better for the keyboard/battery life? Always connected and 100% charge or always charging-discharging when full?

 

Thanks in advance.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...