Jump to content
Corsair Community

HS70 - mute button mutes the audio as well as mic?


Recommended Posts

Hi, I'm a new user - hopefully someone can advise.

 

I'm using HS70s on my work laptop for video calls and stuff, and have been for a few weeks. As this is a work laptop I can't install the iCUE software (I've installed iCUE on my personal gaming laptop and have no issues on that machine at all).

 

Over the last couple of days, my headset has started behaving differently - when I press the mute button it mutes the audio as well as the microphone. Unmuting doesn't do anything - once it's muted I can press the button as often as I like and I still can't hear anything/mic is muted too. I have to eject the bluetooth dongle and plug it back in to get audio back.

 

Is this something that I can resolve or am I just going to have to deal with it?

 

TIA

Link to comment
Share on other sites

  • Corsair Employees

Hi Fraser,

 

I would suggest reseting your headset

 

Many similar issues on our HS70 can be solved by doing a Soft-Reset. This will disconnect the battery from the headset, and then reconnect it. All you need to do is:

1.Make sure your HS70 is powered off.

2.Hold the Mute button on the HS70 headset down for about 15-20 seconds

3.After holding the Mute button wait 15 seconds and then hold the Power button until the HS70 turns on.

 

Then try testing the headset. If it is still having issues, please contact us again for further troubleshooting.

 

Contact Support @ https://help.corsair.com/hc/en-us

 

They can help you with this issue.

Link to comment
Share on other sites

Hi,

 

I tried this and it resolved the issue :)

 

Quick observation - the first time I tried this, the headset was plugged in to charge and the reset didn't resolve the issue.

 

I unplugged the headset from power and re-ran the reset process and it did work.

 

Thanks!

Link to comment
Share on other sites

  • 8 months later...
On 2/2/2021 at 1:03 PM, Corsair Elito said:

Hi Fraser,

 

I would suggest reseting your headset

 

Many similar issues on our HS70 can be solved by doing a Soft-Reset. This will disconnect the battery from the headset, and then reconnect it. All you need to do is:

1.Make sure your HS70 is powered off.

2.Hold the Mute button on the HS70 headset down for about 15-20 seconds

3.After holding the Mute button wait 15 seconds and then hold the Power button until the HS70 turns on.

 

Then try testing the headset. If it is still having issues, please contact us again for further troubleshooting.

 

Contact Support @ https://help.corsair.com/hc/en-us

 

They can help you with this issue.

@Corsair Elito

Hello,

I am experiencing this same exact issue, except the reset only fixes it until the next time I use the mute button. Please advise.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...