Jump to content
Corsair Community

iCue & Asus Integration Broken


Axemasta
 Share

Recommended Posts

Hi All

 

In 2020 I changed motherboards from a Gigabyte X570 board which had issues and is currently "being repaired" to an ASUS Strix X570-F board. My old board lacked RGB and it was a welcomed sight to see the RGB integration with iCUE on the ASUS board. I have had 3 months of usage and everything has worked perfectly up to the point, I like having a Color Shift linked profile so everything I have (my eco system is entirely icue) changes gently between colors.

 

Yesterday I upgrade my case to the Lian Li O11 Dynamic XL which I've been after for ages, add in a new H150i Capellix and 6 QL fans, I'm pretty stoked at the results. Initially the RGB was working perfectly on the ASUS and I was looking to sync the Lian Li RGB to the Motherboard. I had not realised this was a setting on the case itself and instead unwittingly loaded up ASUS Armoury Control and changed the settings. I got the case and motherboard syncing up but this has now broken the integration with iCUE.

 

I tried reinstalling everything and cleaning things (side note, the ASUS programs leave alot of junk behind and the chipset software doesnt even uninstall...). I flashed the motherboard bios and reinstalled windows, no change.

 

The motherboard iCue integration at the very least is possible, I've seen it with my own eyes. Now I can't seem to get the iCUE to talk to ASUS.

 

What API's are corsair using to talk to ASUS? I would like to investigate which services I can / cant disable from ASUS. If ASUS is overriding the iCUE all we need to do is figure out what is taking control away and stop it. I tried collecting debug logs from iCUE and changing colors but I cant seem to find any errors. Any ideas on how I can get this back up and running?

 

My temporary fix is to set iCUE and AC to the same color so everything matches.

 

*Also ASUS Aura appears to be invalidated nowadays, I tried installing but it wouldn't load up. AC is the only tool that is supported leaving many instructions out of date :/

Link to comment
Share on other sites

Fixed by rolling back to plugin version 1.0.4, No integration with the o11 dynamic mind. That was a waste of reinstalling windows

 

If they could just whack the source up on GitHub, I'd happily take a crack and fixing and supporting the asus rgb headers!

Link to comment
Share on other sites

Fixed by rolling back to plugin version 1.0.4, No integration with the o11 dynamic mind. That was a waste of reinstalling windows ��

 

If they could just whack the source up on GitHub, I'd happily take a crack and fixing and supporting the asus rgb headers!

 

Hey, I am suffering the same issue as you did - what exactly did you roll back to 1.0.4? I am new at this, not very proficient in rolling updates back, but have been infuriated that my Mobo will not work with iCue.

Link to comment
Share on other sites

 Share

×
×
  • Create New...