Jump to content
Corsair Community

Corshair headset stand suddenly causes issues


Recommended Posts

Greetings. Did some research but could not find a sollution.

 

I got complete set of corshair and been very happy with it. But sins day or 2 the headset stand causing problem and first noticed it when my wireless void refused to show up. The stand lights up fine, shows up in the software and dongle light goes on, if void is off the dongle goes on and off the light and when void turned on it steady on but void wont connect and wont show up in the software.

 

Both usb ports seem to work atleast power wise but connecting usb stick wont open them but connecting my phone for example does charge it. But connecting my micepad polaris or mice both stay dark and wont work on the stand.

 

Connecting void dongle anywhere els like keybord or mousepad or on pc directly all fine.

 

I tried.

Uninstall and reinstall icue.

Uninstall other third party software like msi mystic lighting.

Force update firmware.

Different usb ports on my pc.

Kinda tried everything I could think of or found online.

 

Find it weird because it always worked fine for years and first thing I though of maybe driver update some where something messed up but rerolled them with no change.

 

Anyone got a idea to solve it?

 

So my GF got same stand and if swap the stand on my pc her one works fine so issue is with headset stand ST100 RGB.

Edited by Azona
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...