Jump to content
Corsair Community

K70 mk2 SE turns red when my computer turns on?


abuchan
 Share

Recommended Posts

I recently bought a k70 mk2 se rapidfire for my computer and I really enjoy this keyboard. The problem is that whenever I turn my computer on my keyboard will go to the profile that I had it set at originally and then all the keys turn red. I open up the ICUE software and try to change it and nothing will change even if I change the profile or the lighting effects. The only thing that seems to fix it is if I close icue with task manager and then reopen it but I would like to not have to do that every time I turn on my computer. I have the latest ICUE software and I have the latest firmware on my keyboard. Please let me know if you know of any way to fix this!
Link to comment
Share on other sites

  • 2 weeks later...

Hei, I got the same issue with my K68. Icue was working strange !!

Corsair Notepad is right, Disabling or Removing MSI Mystic Light, solves the problem.

Steps to follow: (in case you don't know)

> Close ICUE completely first.

>Press Win+R key together to open RUN,

>type " services.msc " inside run & hit Enter.

>there scroll down until you find " Mystic_Light_Service ",

>Than Double Click on that,

:if Status is running, Click on "Stop"

:if Startup Type is "Automatic" or "Automatic(delayed start)", click manual or disable.

> hit "apply" than "ok"

>exit out of services, and restart once!

Hope it will work!

MSI.thumb.PNG.c329b78ebbebe0a1b1c4484179d1e36f.PNG

Link to comment
Share on other sites

 Share

×
×
  • Create New...