Jump to content
Corsair Community

Void Elite RGB USB


Recommended Posts

iCUE told me the firmware needed updating and now the headset starts crashing every time I try to use the microphone. Have tried forcing iCUE to update firmware but its saying its 0.01 and wont update.

 

Does anyone know where to get a firmware image of correct version? Seems stupid to have that option and not supply them on their website.

 

I did a whole clean install and it worked fine for about 5 minutes until iCUE caught up and did the firmware thing again :/

Link to comment
Share on other sites

Forced update hasn't worked, either gets stuck half way or completes but stays on the seemingly corrupt version. Reached out to support for a firmware image but they refused to supply one.

 

Guess I am stuck hoping they release an iCUE/firmware update that works

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...