Jump to content
Corsair Community

Harpoon RGB Wireless Connection Issues


Recommended Posts

Today for some reason my mouse refuses to work in wireless mode. Bluetooth or 2.4, it does not do anything to help.

 

I've tried uninstalling and reinstalling iCue. I've tried updating the firmware, nothing. I've reset the mouse multiple times, nothing changes. iCue only shows a mouse firmware version now. For the USB dongle it just says "v.?". Windows doesnt even seem to detect the dongle anymore.

 

For over an hour now i've been googling my issue and trying to troubleshoot, can't find any real answers. Please, if anyone has a solution please share, I just spent 40 dollars on this because I wanted to go wireless, and now the main feature is useless.

Edited by ArmenianPepsi
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...