Jump to content
Corsair Community

Corsair K70 MK2 RBG F1 key bug


Recommended Posts

Hello, first time poster here.

Problem started today.

Out of no where, my F1 key started to be unresponsive.

Tried it on another computer, same problem.

Tried resetting they keyboard by unplugging and holding the escape key, never blinked as it said it should.

I changed my RBG settings to light up when a key is pressed and it lights up the F1 key. It's simply unresponsive on every program I tried it on, yet the switch doesn't seems to be broken since it lights on.

I have no macros saved at all.

Please help!

Link to comment
Share on other sites

Can you elaborate on the circumstances where F1 does not work? In a specific application? Does not open a new tab in a browser? Not performing expected function?

 

Try working this from the software end and run a repair of iCUE. Windows Apps -> lecft click on "Modify" for Corsair iCUE. Follow the prompts for a repair install. This will not remove profiles or settings, but can be useful for cleaning up weird issues.

Link to comment
Share on other sites

As a test, create a new action (+) and change it from Macro to A-Z map. Pick a letter and assign it to F1. See if it will output the new assignment in this or any text field.

 

We have seen some CUE bugs with Function keys outputting the something else (numbers, G-keys, etc). That is not something that has been reported on the current version of CUE. It did exist quite a few versions back. Make sure you are not still using v3.22 or something that old.

 

We need to find a way to separate a software problem from a hardware problem. An easy way to that is to quit CUE from the > in the task bar, then hit F1 with your browser open to see if it opens up a new tab.

Link to comment
Share on other sites

If F1 won't open a browser with CUE not running (full quit, not just minimized), then there may indeed still be a problem with the KB itself - despite the switch working.

 

I would contact Corsair Support at this point. It's possible a force update of the firmware could resolve it. You might also take another try at the soft reset. I am not sure why it didn't work before.

 

https://help.corsair.com/hc/en-us/articles/360025465031-How-to-Reset-your-keyboard

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...