Jump to content
Corsair Community

Corsair Virtuoso has crackling Sounds (Wireless)

Recommended Posts

Hey, I just got my Corsair Virtuoso a couple days ago.


Somewhere between today and yesterday I noticed the Audio Quality has some crackling to it no matter what I'm doing if I run it in wireless mode.


I've set the EQ back to Pure Direct, switched USB Ports and disabled USB power mode settings by now, but the issue won't stop.


I've also tried to see if it's a hardware issue and hooked the headset to PC directly via USB and that works flawless.


What else could cause this? I have the latest iCUE and Firmware for HS and Dongle installed. No other Audio Drivers (had to uninstall Realtek and some ASUS AI Noise Cancelling Software before because Mic Quality was really bad).

Link to comment
Share on other sites

  • Corsair Employees

Hi saik1992,


Sorry to hear about the crackling sounds you're experiencing. Which audio quality is selected in the headset's properties? I also suggest attempting a soft reset on the headset. To soft reset your headset:


1. Make sure your headset is currently unplugged.

2. Make sure your headset is powered on.

3. Hold the Mute button on the headset down for about 15 seconds.

4. Switch the headset off and then back on.

5. Test your headset and see if the issue is resolved.

Link to comment
Share on other sites

  • 1 year later...

I know this thread is old, but if anyone else is having this issue, even AFTER trying the soft reset, then you should try moving the USB dongle to a different bank of USB ports. I have this issue when I plug the wireless dongle into a USB hub (especially when plugging it into the integrated USB hub of a monitor, for example.) I find that plugging it in directly to the motherboard prevents this issue from happening [to me]. My case's USB ports will have it happen occasionally, but I've never had the issue with it plugged directly into the motherboard. 

A powered USB hub might be different, but I don't have one to test it with. 

Link to comment
Share on other sites

  • 10 months later...

I have a powered hub does not help it is a firmware issue with the headset and icue 4 and their is a huge post for the virtuoso RGB at this link


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...