Jump to content
Corsair Community

H115i not recognized by iCue

Pan Azmodues

Recommended Posts



Yes I went through the forum before asking this question but none reflect my build or contain a solution that worked.


Here the situation about RGB lighting in iCue: corsair's software does recognize everything but the H115i platinum liquid cooler and it's 2 ML 140mm fans. What is needed to make it recognize them?


I have this build:

* AMD 5900X

* Asus Strix E-Gaming X570 MoBo (recognized by iCue)

* ASUS TUF GAMING RTX3070 OC (recognized by iCue)

* Vengeance Pro 64Gb (recognized by iCue)

* 1x SP RGB pro 120mm fan (recognized by iCue)

* 2x SP RGU pro 140mm fans (recognized by iCue)

* 1x Lightning node core (not shown in iCue)

* 1x Commander Pro w/ 4 thermal sensors (all recognized by iCue)

* 1x H115i Platinum Water cooler with 2 ML fans (not recognized by iCue)

* Case: 4000D Airflow from Corsair


General connections:

The pump is connected to the MoBo through CPU_FAN and the micro-usb cable on the AIO pump is connected to the Commander Pro's USB 2-port . The lightning core that came with the SP RGB PRO 140 dual pack is also connected on the Commander Pro by its USB 2.0-port.


FAN connections:

All RGB Pro fans are connected to the Commander Pro for power and to the lightning core for RGB in same order.


The ML 140mm fans from the water cooler are connected with the AIO-pump and that both power and RGB.


Everything is lightning up, it's just iCue that doesn't see the H115i and it's fans.



What I do see is this notification in the settings from Commander Pro that an Hydro X is detecetd. Running the wizard I can't select any fan since they are also not present and recognized. They are connected to the AIO-pump, not the Commander Pro. I did so cause I thought no different fan types might be mixed up and to leave those fans connected with the pump is better.


Hydro X, that's a different thing?


What's wrong? Or should I connect the ML fans's RGB and power to the lightning core and commander pro respectively and run the wizard for this Hydro X?


The iCue software


Edited by Pan Azmodues
Link to comment
Share on other sites

No more a matter:


I've solved this by unplugging and replugging the USB2 cables from the Commander Pro to Node core and H115i and SATA cables from H115i and Node core and restarted windows. The OS and iCue now recognize this 2 instantly.


I'm still puzzled as to why this is the solution. Those cables were firmly connected!


Anyway it's solved.


Now for the already recognized ASUS motherboard and graphics card to respond in iCue.

Link to comment
Share on other sites

  • Create New...