Jump to content
Corsair Community

LS100 kit is not working as it should


Recommended Posts

LS100 kit is not working as it should, I've had it for a while, at first it was working properly, then it started acting weird, got fixed later for some reason, it randomly started working again but now its broken again.

 

Seriously, I've had nothing but problems with this kit, what a mess, Im pretty sure its firmware/software related...

 

  • one of the strips doesnt fully light up now,
     
  • having the lights changed to white for example, and they randomly start showing some other colour along with white
     
  • messing with the opacity changes the lights colours as well wdf
     
  • video lightning is a complete mess, displays each led with random colours..

 

Heres a video demonstrating the issue , Im just messing with the opacity here and as you can see, its changing colours like a madman..

[ame=

]
[/ame]

 

Is there a way to get older firmwares or icue versions? I've tried reinstalling iCue but the issue persists, also tried forcing a firmware update, but doesnt work either

Link to comment
Share on other sites

  • 2 weeks later...

Unfortunately LS100 is very badly supported... I'm using a Starter kit + 2x250 strips with my ultrawide monitor and I can't set anything else than a static color. But also this very basic effect acts weird a couple of times per day, one of the strips starts to show some kind of purple or light blue instead of white. Every other effect is unusable as it stops working after a couple of minutes or does not work at all. Only solution is to unplug both power and USB connections, that is very unconfortable. Also the hub's button never worked for me (it's supposed to change brigthness, I think).

I can't see why Corsair does not provide an update to arrange the strips the way they really are... I'm using the double monitor setup as it's the only one that works for me, but it's a short-long-long-short-long-long set, while I'm using short-long-short-short-long-short scheme to fully cover my monitor.

 

Sadly I must say it's my worst experience with a Corsair product. :(

 

Baio

Edited by Baio
  • Like 1
Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...