Jump to content
Corsair Community

Combined Keystrokes coming through individually (possible bug?)


Alweth
 Share

Recommended Posts

I am trying to use iCUE with my new K55 keyboard to play Pillars of Eternity, and I'm encountering the following unexpected behavior:

 

In Pillars of Eternity, pressing F5 initiates a Quicksave (by default), but pressing Shift + F5 does not.

 

However, when I bind a Macro (G) key to do the keystroke Shift + F5, it seems to be detected by Pillars of Eternity as if F5 was pressed individually. That is, it initiates a Quicksave when the Macro key is pressed, and when I press the Macro key in the control binding settings of Pillars of Eternity, it is detected only as F5, not as Shift + F5. However, if I bind an action in Pillars of Eternity to Shift + F5 manually, then pressing the Macro key triggers that action when simply pressing F5 doesn't.

 

I had the same issue when I tried to create the same effect with a Macro instead of a Keystroke.

 

Is this a bug? How would I get a Macro key to act like a I'm pressing Shift + F5, but only Shift + F5?

 

Thanks for any help!

Link to comment
Share on other sites

I've been able to get the behavior I want by creating two separate Macros, one that presses the keys I want in the order I want and one that releases them in the reverse order, and then assigning the release event as the second event for the first macro. But I would think there has to be an easier way to do this. Do any of you know the easy way to do what I'm trying to do?
Link to comment
Share on other sites

 Share

×
×
  • Create New...