Jump to content
Corsair Community

Discoloration with Corsair H100i RGB Platinum SE


grxffin
 Share

Recommended Posts

Hello, I have some discoloration with Corsair H100i RGB Platinum SE, when set to white, the color has a warmer, tan look then all of the other colors in the PC. Does the pump not support cooler whites is there an error in the pump, I cant remember this happening when it first arrived.

 

[see attachments]

 

IMG_5084.jpg?width=936&height=702

 

IMG_5085.jpg?width=936&height=702

 

Product link: https://www.amazon.com/Corsair-Hydro-H100i-PLATINUM-Radiator/dp/B07R6YLDDS/ref=sr_1_1?dchild=1&keywords=corsair+h100i+white&qid=1609091344&sr=8-1

Link to comment
Share on other sites

This is not even remotely close to the white you should see.

There are plenty of pictures/videos of this AiO online and white is well WHITE.

I've personally seen two units and both of them are showing true bright cold white color.

Link to comment
Share on other sites

This is not even remotely close to the white you should see.

There are plenty of pictures/videos of this AiO online and white is well WHITE.

I've personally seen two units and both of them are showing true bright cold white color.

What do you suggest I do? Contact support?

Link to comment
Share on other sites

What do you suggest I do? Contact support?

 

This is what people generally recommend here and what Corsair employees here recommend. From what I've seen here and at r/corsair they're pretty consumer-friendly.

 

If you are in Europe, you have quite powerful consumer rights. You don't have to reach out to Corsair - you just contact the seller and request refund/new non-defective unit. Moreover, you can return any item bought online in 14 days. I did the latter with my defective H100i - used 14 days return and got a new one.

Link to comment
Share on other sites

Looks like you are missing some blue from the 255/255/255 white color. Try setting a 0/0/255 blue and see how it looks.

 

Only other suggestions are:

 

1) Quick CUE repair from Windows Apps->Settings. Takes 30 seconds and no data loss. Not likely to resolve it, but can be helpful for weird issues.

 

2) Force update the firmware on the cooler. Check for update (none available) -> Force update. The cooler will go offline and the fans loud for 5 seconds while it reloads.

However, be aware firmware flashes are not entirely risk free. If you would rather wait for Corsair to provide instructions, you can. Since the color is not affecting the normal cooling operation, there isn't a critical need to resolve it immediately.

 

Neither of these will help if the Blue LEDs aren't working, but since the color is relatively uniform, these seems like a glitch rather than hardware failure.

Link to comment
Share on other sites

 Share

×
×
  • Create New...