Jump to content
Corsair Community

Installing iCUE freezes my PC


Recommended Posts

Hello everyone,


I got a Corsair Scimitar RGB Elite yesterday and wanted to install iCUE for it but every time it freezes my Win 10 PC (I have to do a hard reset) and the single time it did work there were a couple of error messages when I tried to actually start it. Tries after unplugging my old mouse and plugging in the Scimitar:


  1. Version 3.36.125 (latest): Freeze at 72% ("Installing driver..."), installing in a "custom" folder for drivers
  2. Version 3.36.125 (latest): -"-
  3. Version 3.35.152: Freeze at 32%, installing in the default folder
  4. Version 3.35.152: Default folder, with both shortcuts (desktop & start menu) disabled. Installing finished but starting the app wouldn't actually start it. Instead I got 4 "0xc000012f" error popups, one for each of these files:
    MobileProto.dll, hueapi.dll, iD-BD_x86.dll, ModelHelpers.dll
  5. Version 3.36.125 (latest): Tried to install on top of the other one but froze at 31% (uninstalling old version), shortcuts were unticked
  6. Uninstall through Windows: Freeze at 31%
  7. Repair: Another freeze
  8. Version 3.35.152: I loaded a Windows recovery point I'd created before I first tried to install iCUE and disabled my antivirus software (and unplugged the lan cable), then tried to install it again -> freeze at 40% (default folder, shortcuts enabled) instead of finishing like previously. I waited 15 minutes but the PC was still frozen.
  9. Version 3.36.125 (latest): Freeze at 30%.


I want to install iCUE because the light effects are annoying (really bright and busy) and I want to change the bindings for the 1-12 keys but I can't do any of that without the software, which makes the mouse unusable at the moment.


How do I make the app finish installing and how do I also make it start afterwards? Is there an even older version I should try?

Link to comment
Share on other sites

  • 2 weeks later...

I just also tested version 3.32.80 but got the same result: When it hits "Installing driver" (42%):

1. Blue "working" circle next to mouse cursor

2. Mouse cursor vanishes

3. Freeze


There was a difference this time though: Before it even got there, it complained about "nVidia web services" running in the background and gave me a choice what to do with it. I picked "close & restart", then it did some work and started everything.


I also got a closer look at the error popups that appeared after restarting after the freeze:

It says „NVIDIA Web Helper.exe – Bad image“

Same error code as above but first for file „C:\WINDOWS\SYSTEM32\VCRUNTIME140.dll“ and after the second freeze (I restarted the install process & it did a "rolling back action") it was for the file „C:\WINDOWS\SYSTEM32\MSVCP140.dll“.


What's going on here? Is there seriously a conflict between iCUE and nVidia's GPU drivers (that's the only way I can explain this)?! As much as I like how well the Scimitar fits my hand, I'm not going to uninstall the gpu drivers or even GeForce Experience!

Edited by Juleru
Link to comment
Share on other sites

  • Create New...