Jump to content
Corsair Community

K70 MK2 not working after firmware (.bin) reset


JulStJean
 Share

Recommended Posts

Hi,

few days ago one led wasnt working anymore so I contacted the corsair support which they advised me to do a firmware reset (they sent me the file K70_MK.2_3.24_ISP.bin)

 

but after that, the keyboard is not working anymore, the keys and neither the leds are working

 

on iCue the device is recognized but a red triangle is showing (see screenshot)

I cannot update it, it stucks at 3% then device is not recognized anymore, i have to plug it back

 

I tried to soft reset it with esc, tried different usb ports (2.0 and 3.0), tried different computer, nothing works

 

any idea ?

 

thanks

 

ZU3Xsp2.png

Edited by JulStJean
Link to comment
Share on other sites

Hi. I am having the same issue, as soon as i power on my pc my k70 RGB Mk2 will not work, even if i unplug and replug it into the usb port, itlights up but thats it. It worked for the first couple of times, but now it doesn't, its so frustrating because looking through these forums it seems to have been an issue with various models of keyboard for the last few years, so Corsair clearly know about it, but don't seem to be doing anything about it. If i had known about this issue i would not have bought one.

 

Cheers

Terrone.

Link to comment
Share on other sites

 Share

×
×
  • Create New...