Jump to content
Corsair Community

My Harpoon RGB Wireless right click can't be used


Recommended Posts

Hello, first time here. So, i bought my Harpoon mice 2 months ago. Works like a char until recently the right click gave out on me. Once tried to re-update the mouse and worked. Tried to do it again when it died again but no luck. Searched in the internet to search what caused this, my biggest worry that it's already collected dust that can tamper the inside of the mouse. Tbh with y'all i've been using it in my not so clean room that i rarely cleaned (but not a dumpster room yet) and i've been sleeping sometimes waking up the mouse was below me yet at the time it worked just fine. Can anybody help what caused this and it's solutions while i will try to clean the inside if it can solve the issue? Thx.
Link to comment
Share on other sites

  • 3 weeks later...
  • Corsair Employees

Hi Hntrz63,

 

Your best bet here is going to be to open a ticket with support -- they can send you a specific firmware version for the Harpoon that might resolve the issue, along with "Hard reset" aka firmware flash instructions for that device.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...