Jump to content
Corsair Community

Scimitar RGB Pro ELITE bricked after firmware update


Recommended Posts

Hey guys,

 

Does any one of you have a firmware file for the Scimitar RGB Pro ELITE mouse? I tried to update it and it failed and everything turned off an its not working. It shows up in my computer as "CRP DISABLD". Already tried the soft reset (left + right click then plug) but it doesnt work.

 

I already opened a ticket but it's going to take forever for them to reply ... If anyonefrom Corsair sees this, could you please help me out? Here's my ticket number 2003839517

 

Thanks!

Link to comment
Share on other sites

  • 2 weeks later...

I have the same issue with my Scimitar Elite (not the Pro version). Completely bricked after the last update. Doesn't work in any computer I've tried it with.

 

Did they ever send you the firmware file? I can't believe that they don't make the firmware files available to download from their site, and instead you have to make a ticket with support and wait for them to send it to you.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...