Jump to content
Corsair Community

Looks like my Corsair One is dead.


xDaredevil
 Share

Recommended Posts

I've posted about my issues here before with my Corsair One but looks like my unit is finally toast.

 

To reiterate I have the 2017 version with a 1080ti and i7-7700k and this is my second unit after RMA'ing the first one for the same problem (freezing and hard crashing while gaming). I've seen that several other users on the forum with the same exact model have had similar issues.

 

This PC works flawlessly if I'm doing anything but gaming. No blue screens or anything but if I fire up a game, eventually the temps get hot, fans get loud and it freezes and my screen looks like tetris blocks.

 

The other day I decided to run corsair diagnostics just to see if maybe this would help. I don't run this often but it proved to be a big mistake.

 

It runs through everything smoothly up until the stress test on the gpu. No surprise, it ended up crashing here. This time though, it seemed to completely fry my card. My PC still boots but it no longer detects the gpu properly and I have a bunch of green and pink pixels all over my screen. For some reason, I've also lost the option to put the PC to sleep.

 

I talk to Corsair support and they tell me pretty much what I expected. They can't do anything because it's no longer in warranty (even though the issue I have with it is the same one I RMA'd it for).

 

They tell me to take it to a repair shop so I do exactly that. I take it to two repair shops. Both tell me it's the graphic card that is the issue but neither one wants to work on it or felt they could work on it because it's "proprietary." I guess they don't want to touch it because it's not a simple plug and play job. So now I have an expensive paperweight with no help from Corsair because according to them (at least from my experience) you're SOL unless you have a warranty and they seem very unwilling to do anything for you otherwise.

Link to comment
Share on other sites

 Share

×
×
  • Create New...