Jump to content
Corsair Community

M55 RGB Pro - remapping buttons problem


skrybe
 Share

Recommended Posts

I'm a leftie having problems remapping buttons on the M55 RGB Pro to suit what I want. I hate to say it but iCue is really un-intuitive :(

 

While I use a mouse left handed it's not completely "flipped" like some lefties. eg: I left click using my middle finger not my index finger. So effectively I use the mouse with a right handed setup, just with my left hand.

 

Where the problem lies is the side buttons. Using the naming from iCue, I want to bind the Right Forward button to the Forward button and the Right Back button to the Back button. However I just cannot get that to work.

 

Steps I tried:

 

1. I went into the settings and enabled all side buttons. Note to devs: It'd make more sense clicking the device then seeing a tab for settings. Not clicking the iCue settings then finding the device specific settings.

 

2. Went back to the devices section for the mouse, chose Actions, and added a new action.

 

3. Picked "Mouse button" from the type dropdown on the right side.

 

4. Picked "Right Forward" from the top-right side and picked "Forward Button" from the bottom-right side.

 

I tested in WoW and if I click the Right Forward button-click nothing happens, my character doesn't move so apparently the button click doesn't register at all. However, if I click the Left Forward button my character moves forward. So it looks like it's ignoring the button mapping.

 

I tried reversing the setup thinking maybe the logic is backwards (ie: I picked the "Left Forward" button at the top and "Forward Button" at the bottom but that appears to work exactly the same.

 

Thinking, maybe it doesn't map at all I tried remapping the "Right Back" to "Right Button" and that works perfectly. Pressing the right back button brings up the right click menu. So remapping obviously works for *some* keys.

 

I also tried "Retain original key output" from the Advanced tab but that didn't appear to do anything.

 

So TL:DR; how do I remap "Right Back" to "Back" and "Right Forward" to "Forward"?

 

edit: I found this thread (https://forum.corsair.com/forums/showthread.php?t=188920) and it looks like it outlines the same steps I tried. But it just doesn't work.

Edited by skrybe
Link to comment
Share on other sites

Ok, so after more testing. It appears that the "Right Forward" and "Right Back" buttons are actually functioning after being remapped. If I use them in Firefox it moves back and forward through pages as expected. Unfortunately they still don't work in WoW. And the left forward and back buttons still work in Firefox as well.

 

So it looks like remapping doesn't actually switch buttons it just duplicates buttons. And I'm guessing left forward and left back are button 4 and 5 which WoW supports. But the right forward and right back are button 6 and 7 which WoW does not support. So frustrating, I've had this remapping setup in Razer, SteelSeries and Logitech mice with no dramas. This is first time it's been an issue.

 

Even more frustrating, I had the thought that if I switch the mouse to left handed mode maybe it'd be easier to remap. I just tried that and by default the right forward and right back buttons automatically become the forward and back buttons. So all I needed to do was remap left and right click... which completely broke iCue. I rebound right-click to left click successfully, but the moment I tried to rebind left-click to right-click iCue crashed. Leaving me with a mouse that would only right click and zero left click functionality. A windows reboot didn't fix it but I managed to launch icue and tab through it using keyboard shortcuts til I removed the remapped keys and the mouse is back to default.

 

So do not try rebinding left-right click keys to each other. It breaks iCue - something Corsair devs need to look at.

 

This is really frustrating since it's obviously possible to transpose the buttons. The "enable left handed mode" obviously does this. But we can't manually transpose buttons using a custom action.

Edited by skrybe
Link to comment
Share on other sites

Ok, so this is even more frustrating. I tried disabling the left back and forward buttons in iCue. I tested in Firefox and as expected neither button worked anymore.

 

I then mapped the right back and forward buttons for back and forward. Tested in Firefox and they worked as expected. The left buttons were still disabled so everything looked good.

 

Tested in WoW and the right buttons don't work at all but the left ones (which should be disabled) still work. What the heck? Now I'm thinking there is something wrong between WoW and iCue. It's as though WoW is selectively ignoring some of the iCue settings but not others. Are there game specific profiles attached to the mouse/iCue? And if there are where do I find them because I can't see them in iCue?

Link to comment
Share on other sites

OMG I finally stumbled onto the answer. I have a WOW profile that I thought was solely attached to my k95 keyboard. It's purely to colour code the keys. But apparently that was firing everytime I launched WOW and so the mouse changes (that worked fine in Windows/firefox) were being completely ignored in WoW. I added the same mouse changes under this profile as well and suddenly it works perfectly in WoW.

 

I just wasted something like 4 hours on this issue, because of the un-intuitive way iCue works. It's just a horrible, confusing setup. It may be super powerful, but man it's hard to use :(

Link to comment
Share on other sites

 Share

×
×
  • Create New...