Jump to content
Corsair Community

Commander PRO fan #1 doesn't change speed sometimes


rdoroana
 Share

Recommended Posts

Hey guys,

 

I've been using a Commander PRO to control all of my PC fans for about a year now, and never ran into any issue until now. I recently changed to a new motherboard and since I formatted my hard drive that I've had issues with fan port #1 on the Commander PRO.

 

Sometimes the fan in port #1 will not respond to any speed changes in the iCUE software. It shows up, it displays the current RPM, but no matter what I set it to, it won't change. I first noticed that a reboot sometimes resolved the issue, as did a forced firmware flash. In an attempt to investigate the situation a bit more I found out that if I quit iCUE and kill all the Corsair Service processes running in the background, I could get the issue to happen again as I started iCUE and the processes started running again. However, this also only happens sometimes (around 1 out of 4 times), and I can't seem to find a 100% consistent way to replicate this. I'll attach my log exports to the post, which clearly show an error in the service logs, but doesn't really tell me anything useful.

 

Also, here is everything I've tried to investigate and fix the situation:

 

  • Formatted twice, being very careful to install all the correct drivers to avoid potential issues there
  • Tried using different iCUE versions but they all behaved the same way (3.33.246, 3.35.152 and 3.36.125)
  • Disabled many background processes in Windows, such as those related with any ASUS software which could be causing conflicts, and tried different combinations
  • Swapped the internal USB port where the Commander PRO was connected to
  • Tried different fans in port #1, but they all had the issue at some point while testing, and they all behave correctly in other ports (which makes me pretty certain it's not a fan issue)
  • Tried resetting the Commander PRO using the pinhole and tried force flashing the firmware (it restarts and works, but then the issue shows up again eventually)

 

I've run out of ideas on what to try next since I've already spent quite a long time looking into this. I'm not sure if it's simply a hardware issue and the Commander PRO just fails to correctly communicate with the Corsair background service sometimes, or if there is some other software which may be causing conflicts. I also have a Corsair Hydro H115i PRO and an iCUE NEXUS which I've never had an issue with and seem to work as expected.

 

Thanks in advance for any help!

iCUE Logs.zip

Link to comment
Share on other sites

It's just non responsive, so it'll be stuck at whatever RPM it was left at when it was last responsive (those times the issue doesn't happen). I also forgot to mention that've tried changing the settings in Commander PRO to select the proper pinout configuration for my fans (instead of leaving it on Auto), in case that's relevant.
Link to comment
Share on other sites

OK. There is a specific glitch on the Commander Pro where port #1 (only) becomes stuck at 100%. This is resolved by a firmware flash. However, it is uncommon and generally non-reoccurring. I had it happen 2 years one time and that is the only time in 4 years with 2 units.

 

Based on what you are describing, I think this is something different. It’s not at max speed and messing with the services would not affect the above problem, which exists at the hardware level.

 

I think it's time to contact Corsair Support. Typically when there is a software conflict, the entire device becomes unresponsive, elements of the UI "disappear", and you get data garbage back (3.3v on the 12v rail, -216C for temperature, etc.). There isn't any reason it would selectively target port 1 repeatedly and only port 1.

 

The only other thing that comes to mind is try removing the cooling config file to check for corruption in that data. Quit CUE app from the task manager, along with Corsair.Service (32 bit).

 

Go to C:Users/(name)/AppData(hidden)/Roaming/Corsair/CUE/Cooling

 

Cut and paste that config file to the desktop. Now re-launch CUE. Fan curves should all be gone and it will have reset to Quiet (along with the resulting fan blast for that). Make the only the custom curve you need right now and see if this holds. If it does not, the old config file can be dropped back in and CUE restarted to get them back.

Edited by c-attack
Link to comment
Share on other sites

I've tried completely uninstalling and reinstalling iCUE multiple times (removing the AppData folders as well as the registry entries as described here) to no avail. Like you said, it's time to contact Corsair Support since I'm convinced something is actually wrong with the unit itself.

 

In the meantime I've resorted to using ports #2 to #6 (luckily I only have 5 fans, so I can skip using port #1) which work flawlessly. It messes with my OCD a little, but having working fans definitely takes priority.

 

In any case, thanks for taking the time to reply, I appreciate the help :)

Link to comment
Share on other sites

 Share

×
×
  • Create New...