Jump to content
Corsair Community

H150i not appearing in iCue


GeeGee28
 Share

Recommended Posts

Hi everyone,

 

I am new here. I am asking if anyone can help.

 

I have an issue where I have recently built my first gaming pc, everything was going fine and until when the updates and drivers were being installed. After that I my H150i Pro XT haas not appeared in iCUE since.

 

I have it connected it to my commander pro where all my fans and rgb points route to and it appears as a connected device in windows but I can't figure why its not showing. The pump feels like its cooling the cpu okay but the rgb has completely disappeared.

 

I have tried connecting the usb directly to the header, changed to a usb to connect to the backplate and removed any program that may conflict with it.

 

I have attached images that may help

 

Any help would really be appreciated :biggrin:

 

- Admin, if in the wrong thread please direct me to the correct page -

 

Many thanks

iCUE.thumb.PNG.b37339b656eae63b10bdc7292d3aa433.PNG

Devices.PNG.7dae58f87e2f80421f55edab3587edd4.PNG

1920521207_Deviceprops.PNG.d339cd08a348519eda09b532789d6bd4.PNG

Link to comment
Share on other sites

You have the USB cable from the pump connected to a USB header on your motherboard correct? And then you have your commander pro connected to a 2nd USB Header?

 

Just confirming how you have everything connected. Assuming everything is connected properly, what i would try next is uninstalling icue and download the current version from Corsair and reinstall it (if you have not tried that already)

 

Sorry, you didn't mention any steps you had tried so i wasn't sure what all steps you have taken so far.

Link to comment
Share on other sites

 Share

×
×
  • Create New...