Jump to content
Corsair Community

Mic Feedback On/Off


Recommended Posts

So I have a set of Vengeance Corsair RGB VOID Pro and usually when sliding the mic up or down I would get an audio prompt that simply said Mic On/Off. However following an ICUE update I did this morning I now get the usual Mic On/Off along with Mic Feedback On/Off giving me like 5 seconds of audio prompting each time... very annoying, especially since mic feedback is set to 0 anyway so I'm not using it. (it should just be off either way) I am making the assumption that by mic feedback its referring to sidetone as I don't know what else it'd be talking about.

 

So my question is, is there anyway to disable the audio prompt for one and not the other? Mic On/Off serves a purpose, the other is unnecessary. I know I can turn audio promts off that would stop both but that's not what I want.

 

Seems weird they've decided to add a new audio prompt for feedback that doesn't really do anything since as far as I can tell it switches on/off identically with the mic on/off.

 

ICUE Version 3.35.152

Link to comment
Share on other sites

  • 1 month later...
Hey guys,

 

Go ahead and update your iCUE to 3.37.140 - your headset's settings should have a box for you to uncheck next "Enable Voice Prompts".

 

I have this issue too. I was going nuts trying to figure out if I did something in Windows to cause the headset to prompt "mic feedback off, mic off" when I press the mute button. I'll go ahead and disable the voice prompts for now, but I'd really appreciate the removal of the "mic feedback off" prompt when you hit the mute button on the headset.

Link to comment
Share on other sites

  • Corsair Employees
I want the prompt of Mic On and Mic Off, but not the feedback prompts. Two different things. It wasn't like this two weeks ago... Dumbest thing ever to have two prompts.

 

Unfortunately the voice prompts are an all or nothing option. You will either have to have them all enabled or disabled.

Link to comment
Share on other sites

Unfortunately the voice prompts are an all or nothing option. You will either have to have them all enabled or disabled.

 

I don't think it's always said "mic feedback off, mic off" when I press the mute button on my actual headset though. I think that's changed in the last couple of weeks somehow. I know my headset used to only say "mic off" if I muted the mic. It's kind of redundant for it to say both. I can understand the "mic feedback off" prompt if you turn it off in iCUE, but it's obviously going to be off if you turn the mic off.

Link to comment
Share on other sites

I don't think it's always said "mic feedback off, mic off" when I press the mute button on my actual headset though. I think that's changed in the last couple of weeks somehow. I know my headset used to only say "mic off" if I muted the mic. It's kind of redundant for it to say both. I can understand the "mic feedback off" prompt if you turn it off in iCUE, but it's obviously going to be off if you turn the mic off.

 

It did not do this before, I just updated my iCUE software and after that, I started getting the double prompts. It is very annoying and needs to be resolved. As has been said before, I want the prompt of mic on/off, but not both that AND mic feedback on/off.

 

The response of "It is just the way it is, deal with it" is very bad from a customer service point of view, since it was not this way with the previous iCUE version. Please fix this.

Link to comment
Share on other sites

  • Corsair Employees
It did not do this before, I just updated my iCUE software and after that, I started getting the double prompts. It is very annoying and needs to be resolved. As has been said before, I want the prompt of mic on/off, but not both that AND mic feedback on/off.

 

The response of "It is just the way it is, deal with it" is very bad from a customer service point of view, since it was not this way with the previous iCUE version. Please fix this.

 

If you have the Sidetone feature enabled in the iCUE software for your headset and mute your microphone you will indeed get both prompts.

Link to comment
Share on other sites

If you have the Sidetone feature enabled in the iCUE software for your headset and mute your microphone you will indeed get both prompts.

 

Thank you, that was helpful. While the "Sidetone" slider was all the way down, when I clicked it specifically to mute it, the second voice prompt stopped. I would still recommend you find a better way to handle that, because double voice prompts are pretty annoying if the sidetone feature is desired.

 

I can't say for sure, but I don't remember that Sidetone slider previously, so that could have been added with the latest release (3.37.140) when I updated.

Link to comment
Share on other sites

  • 2 weeks later...
If you have the Sidetone feature enabled in the iCUE software for your headset and mute your microphone you will indeed get both prompts.

 

And you couldn't have said this from the start? Glad I checked this again. I got another headset at Christmas and just got it hooked up and had the same prompts. Now we know how to disable it...

 

I just took my old headset to another machine and it didn't do this, thankfully.

Link to comment
Share on other sites

  • 2 weeks later...
  • 1 month later...
To add to this, I had to go into the Sound settings, Recording, then check "Listen to this device", Apply, then uncheck "Listen to this device", and click Apply again. That solved the issue.

 

Thanks! This worked! Stopped the annoying "mic feedback off/on" prompt but left the "mic on/off" prompt.

 

Cheers!

Link to comment
Share on other sites

  • 2 months later...
  • 3 weeks later...
To add to this, I had to go into the Sound settings, Recording, then check "Listen to this device", Apply, then uncheck "Listen to this device", and click Apply again. That solved the issue.

 

Since I installed the latest version of the iCUE software, this was happening to me as well. When I hit the mute button on the headphones, it would say "mic feedback off. Mic off" and "mic feedback on. mic on" as I muted and unmuted the mic. This was very annoying, especially when I'm on a zoom call trying to listen to other participants as I mic'd in and out of the conversation. Anyway, thanks again for finding a solution to this problem, at least.

 

I have another issue, however.

 

Before I installed the iCUE software, the mic button would make beeps indicating whether it was turning the mic on or off. This was fantastic since it was short, didn't interrupt what I was listening to, and worked quickly. Ever since I installed the iCUE software, it started saying "mic on" and "mic off" instead of the beeps which was not only annoying, since the beeps indicated the mic status quickly, but did not interrupt what I was listening to for very long. I found the setting to turn off voice prompts, but when I turn voice prompts off, it turns all indication for mic status off. It doesn't even make the beeps anymore. The only way I can enable the beeps now is to close the iCUE software completely or uninstall it.

 

I have almost all Corsair hardware in my computer. The case, memory, CPU cooler, all fans, etc are all corsair products, so I must have the iCUE software if I want to control the color scheme through the commander pro I have installed. Ultimately, I must deal with the "mic on" and "mic off" indicators if I want the headphones to audibly report the mic status.

 

Does anyone know how to turn off the dang voice prompts while leaving the mic indicator beeps enabled?

 

C'mon corsair. If you personally used your headphones for zoom meetings, gaming, or anything else for that matter, you would have to know that the beeps are much better than listening to a stupid voice as you mic in and out of conversation.

 

Thanks,

Newtrawn

Link to comment
Share on other sites

  • 4 months later...

i fixed this issue by closing icue, going into the "C:\Program Files (x86)\Corsair\CORSAIR iCUE Software\sounds\default" folder and removing the "sidetone on" and "sidetone off" wav files, then start up icue again. will probably have to do it again if you update icue though. hope this helps.

Link to comment
Share on other sites

  • 1 month later...
  • 1 month later...

o problema não está no aviso de áudio e sim nas pessoas que não leem o manual de instruções!!!

o mesmo botão que ativa/desativa o microfone, também ativa/desativa o feedback de microfone( que acho que é o que irrita pois você ouve sua voz enquanto fala).

para ativar/desativar o microfone, basta pressionar o botão levemente.

para ativar/desativar o feedback do microfone, mantenha pressionado por 5 segundos.

 

espero ter ajudado!!!!

 

Link to comment
Share on other sites

  • 1 month later...

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...