Jump to content
Corsair Community

Anyone know if this works on an M1 Big Sur Machine


Jigs Gaton
 Share

Recommended Posts

I have an M1 Mac Mini and the iCUE software works. HOWEVER, with no mouse movement, its CPU usage sits at 4%, and spikes to 25% continuous usage when I move my mouse around the screen. It's a noticeable drag on the system and I'm considering replacing my mouse. This seems similar to the AMD problems the software had that took Corsair FOREVER to fix so I don't expect any fix soon.
Link to comment
Share on other sites

Works on mine but having the software up can create some sluggishness and a few times now I am pretty sure it caused the system to logout/reboot. I also noticed it loaded an audio driver despite the fact I am using it only for a mouse. Unloading and removing the driver is seeming a challenge. You may want to skip until they create an Apple Silicon version.
Link to comment
Share on other sites

  • 5 weeks later...
i just damaged my keyboard because it kept disconnecting, ended up damaging the port to where the wire. goes in or something now it won't even see it... UHHHH so frustrating. However, as usual Corsair comes to the rescue! I'm running the latest version of iCue on my M1 Mac Mini everything is working except for the audio, i can however still use the Void Pro headset, just can't use the features. Edited by BlackScorpion
Link to comment
Share on other sites

  • 2 weeks later...
  • 4 weeks later...

I have a MacBook Air M1 and the Scimitar RGB Elite, and I can confirm iCUE and the mouse work. However, it didn't work at first. The software wouldn't recognize it. You also need to enable the driver in system settings/security/general.

I also tried to reset the mouse by pressing and holding both mouse buttons while plugging it in but the lights did not flash.

After a few more tries it somehow worked.

Now I am trying to figure out how iCUE works because mapping keys to the buttons is not obvious to me.

Link to comment
Share on other sites

  • 4 weeks later...
I know there is an audio issue with Big Sur.

After installing latest iCUE for MacOS Big Sur on M1 chip, my output audio stopped working for H60 pro headset, although my strafe keyboard works just fine. Would really enjoy 7.1 audio here :/

Also, ckb-next is dropping support for MacOS, which will probably mean that we will be needing iCUE for macOS to work properly more now than ever

Link to comment
Share on other sites

 Share

×
×
  • Create New...