Jump to content
Corsair Community

HX1200 and HX1200i - System not powering on or posting to BIOS


Recommended Posts

  • Corsair Employees

We have recently discovered an issue affecting select units of our HX1200 and HX1200i Series power supplies. Affected units may exhibit compatibility issues with some motherboards - the issue will typically manifest immediately, or shortly after, installation and presents as connected motherboards failing to POST. Only units within lot codes 2030XXXX to 2041XXXX, sold after July 20th, 2020 are affected - please see the below image to identify your lot code. As a result, we are requesting that all inventory in the affected lot code range be sent back to CORSAIR immediately to prevent further distribution to end users.

 

The issue has zero risk of damaging end-user hardware, but we are mindful of the negative user experience this may cause for customers and wish to avoid it if at all possible, especially as the issue is not consistent across all motherboards and can be difficult to diagnose.

 

End users with HX1200 and HX1200i power supplies in the affected lot codes may contact CORSAIR customer support directly to arrange for an advanced replacement unit. However, as there is zero risk to hardware, and the problem will present immediately or shortly after installation, we are choosing not to issue a full recall at this time.

 

How to read CORSAIR lot codes:

YYWWXXXX

2030XXXX

 

YY = Year = 2020

WW = Week = 30th week (20 Jul)

XXXX = Manufacture code

 

To setup your Advanced RMA, please contact our customer service team through the following portal, and one of our agents will assist you with the process.

 

https://help.corsair.com/hc/requests/new?ticket_form_id=360001247391

Edited by Corsair Nick
Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...