Jump to content
Corsair Community

Extreme unstability with the Virtuoso RGB


djmulder
 Share

Recommended Posts

Hey folks,

 

So I truly like the sound on this headset, but there's just something wrong with either the software or just the way it likes to mess with windows.

 

In WoW, when I swap the headset to wireless mode (or back, doesn't matter) it just crashes WoW. The whole "is not responding" and all that jazz.

 

Discord just doesn't want to notice the headset unless I fully reset Discord. Same goes for youtube and chrome. What I also notice that the windows sound subsystem stops working.

 

What the h* is up with this thing? Is it the software? I hear stuff about that icue slipstream, should I just go there?

 

Anyone have experience with this and namely a good idea how to fix it?

Edited by djmulder
Link to comment
Share on other sites

  • Corsair Employees

When switching from wireless to wired mode on the Virtuoso, the headset is detected as a different device by windows and various applications. This is intended behavior so that the headset can operate at a higher sample rates while in USB mode.

 

In discord and your Advanced Sound Options (Windows Sound Settings), do you have the sources set to default or specifically the headset?

Link to comment
Share on other sites

  • 3 weeks later...
When switching from wireless to wired mode on the Virtuoso, the headset is detected as a different device by windows and various applications. This is intended behavior so that the headset can operate at a higher sample rates while in USB mode.

 

In discord and your Advanced Sound Options (Windows Sound Settings), do you have the sources set to default or specifically the headset?

 

I tried both (so individual headset and default).. am considering some alternative software like audiocable.. perhaps that fixes it..

Link to comment
Share on other sites

 Share

×
×
  • Create New...