Jump to content
Corsair Community

Corsair Dark Core wireless quit working


Godryc
 Share

Recommended Posts

Corsair Dark Core wireless quit working. Only works when plugged in now.

 

icue shows two Dark Core mice now - Dark Core Pro USB Mode, and Dark Core Pro Unavailable. When I unplug the USB cord, the Dark Core USB Mode disappears from icue, and the Dark Core Pro Unavailable disappears when unplugged.

 

I have tried different USB ports and unplugging all other USB devices.

 

I have reinstalled icue.

 

I tried plugging it into my laptop as well and the symptoms are identical.

 

What is going on and how do I fix this?

 

QBuozhV

 

EDIT: Not sure why the image is not displaying so here is the link: https://imgur.com/QBuozhV

Edited by Godryc
Image not disaplying
Link to comment
Share on other sites

Hi Godryc,

 

Have you tried re-pairing the wireless dongle? You should be able to initiate USB Wireless Receiver Pairing via the Dark Core's device settings.

 

Yeah, it shows two Dar Core Pros now. One wired, and the other wireless. Sometimes icue force closes itself, that part is new.

Link to comment
Share on other sites

I think I will return the mouse. This has turned into far more trouble than it is worth so far. My recommendation to Corsair: Fix icue and fix your mice. Make it so they work out of the box instead of needing to fiddle endlessly with a piece of frustrating software to get it to work as advertised.
Link to comment
Share on other sites

  • Corsair Employees
I think I will return the mouse. This has turned into far more trouble than it is worth so far. My recommendation to Corsair: Fix icue and fix your mice. Make it so they work out of the box instead of needing to fiddle endlessly with a piece of frustrating software to get it to work as advertised.

 

Sorry to hear, Godryc - I understand your frustration. We are continuously optimizing iCUE. Unresponsive wireless connection is not normal. If you don't mind me asking, how long did you use the mouse for before the wireless connection became unresponsive?

Link to comment
Share on other sites

 Share

×
×
  • Create New...