Jump to content
Corsair Community

Corsair VIRTUOSO RGB WIRELESS Mic Does not work with Corsair ST100 RGB


Djabolic
 Share

Recommended Posts

Hello,

 

I've recently bought Corsair Virtuoso RGB (non SE version) and I've noticed that the microphone does not work when it's plugged in to Corsair ST100 RGB in USB mode.

 

I've tried connecting ST100 to both USB 3.2 Gen 1 and Gen 2 ports on the back panel of my motherboard neither of ports fixed the issue. I know ST100 is USB 3.1 passthru but my motherboard (ASUS ROG MAXIMUS XII HERO WI-FI Z490) does not have any USB 3.1 ports on the back panel IO.

 

BUT

 

If I connect it to front panel USB 3.1 port on my case (Corsair Obsidian 500D RGB SE) it works perfectly without any issues.

 

I've tried every possible combination, uninstalling iCUE and reinstalling, disabling automatic driver installation, restarting thousand times in between and I'm pretty sure the ST100 USB passthrough is the culprit here.

 

Please help.

 

Edit: Ok after few more iCUE reinstallations, mic started working in USB mode while it's connected to ST100 but after that I went away from computer for like 20 minutes now mic over USB stopped working again.

Edited by Djabolic
Link to comment
Share on other sites

  • Corsair Employees

The ST100 actually has a USB hub in it, and is not a pass-through. For Virtuoso, we recommend connecting the dongle either directly to the back of the motherboard, or a front USB rather than through a USB Hub for the best performance. If you continue to run into issues, reach out to our Technical Support team, and they can walk you through additional troubleshooting steps:

 

https://support.corsair.com/

Link to comment
Share on other sites

 Share

×
×
  • Create New...