Jump to content
Corsair Community

HS70 XB Issue


Guineapig
 Share

Recommended Posts

Hello, received my HS70 XB yesterday and I've been having a connectivity issue with my Xbox Series X (have not tried on a Xbox One X).

 

This issue only seems to happen when playing games, this issue does not occur when watching Youtube TV. When playing a game (tested on multiple games) everything works fine until no input is pressed on the controller for about 10 seconds. The sound then cuts in and out and gets choppy. After I press an input, or move the stick the sound works perfectly again until no input is pressed for 10 seconds. This is annoying for games with cutscenes and I really noticed it playing Assassin's Creed Valhalla. Has anyone noticed this issue?

 

I thought it could be interference from wifi or other devices but when I watch youtube TV this issue does not occur...i'm at a loss. Hopefully this can be addressed with a firmware update. Just looking for others experiences, maybe I have a bad unit?

 

Thanks

Link to comment
Share on other sites

Hello,

I have the same issue, very disappointing on Valhalla. I read on internet that is a problem with all enhanced games for series X and I try with TETRIS, so also with it I have the problem. Meanwhile, on destiny 2 (not enhanced) I haven’t any audio problem. I Read a lot of people with problems with turtle beach headsets so I think (and I hope) it’s a Microsoft problem and not an headset problem. You can solve this with clearing caches, but everysingle time you need to start the consolle, very annoing. I hope someone will fix it, tell me if you find any other solutions or updates

 

Thanks

Link to comment
Share on other sites

 Share

×
×
  • Create New...