Jump to content
Corsair Community

Corsair Vengeance RGB dont work with Mystic Light


MFB1205
 Share

Recommended Posts

Hello.

I have a problem with my recently ordered Corsair Vengeance RGB PROs.

They dont show up in mystic light.

I reinstalled Mystic Light several times, switched to different versions and installed and uninstalled ICUE a couple of times but nothing worked.

 

I already wrote the corsair support but the message i got was basically "It should work try to uninstall ICue (which already was uninstalled) or ask msi"

But MSI logically cant help me when a product from corsair doesnt work with their open source software.

 

Do you guys have any ideas what I could try?

I found nothing on the internet.

Link to comment
Share on other sites

  • 5 weeks later...

Hi, I was able to get this to work by installing Dragon Center - running it as Admin - restarting - installing iCUE - restarting - verified that the Vengeance RGB ram was now showing in Mystic Light of dragon center .. went back into the iCUE software > Settings > "Enable Full Software Control" - needs to be enabled.

 

After doing this my vengeance ram is now in sync with everything else.. woooo.

Link to comment
Share on other sites

  • 2 weeks later...
I'm having the same issue. I did what you did (Install Dragon Center, the ICUE, etc.) ang got it to show up in Dragon Center once, but I can't get it back. Bummer

 

Same. Exact. Issue. on my end as well.

Got it to show up once following these directions.

The relationship survived a few restarts.

Then on the 4th or so reboot they lost connectivity and the ram disappeared from Dragon Center.

Link to comment
Share on other sites

  • 2 weeks later...
I feel like this was not an issue with the stock firmware. I wish Corsair was hosting the older firmware versions so we could check. I never had any issues with Mystic Light when I was on stock firmware. Now even if I can sometimes manage to make the rams sync with Mystic Light through iCUE, I'm having issues like flickering, etc.; and the moment I lock my pc the link is broken and does not restore until after some tinkering and a couple of restarts.
Link to comment
Share on other sites

Hey all. I have a similar question/problem. I have an MSI MPG X570 Gaming Plus motherboard, Coolermaster Masterair CPU cooler, and Phanteks P600A case. I finally got it all working with Mystic Light last night, only to have it revert back today.

 

Now, I only see "MB" in my Mystic Light UI. Last night, I had a bunch of stuff showing up there and everything was nicely synced up in terms of lighting.

 

Hoping someone finds the magic solution to this.

 

I have tried all that is suggested thus far and can't get the RAM to show back up in Mystic Light.

 

Thank you in advance.

Link to comment
Share on other sites

  • 11 months later...
  • 3 months later...

Since at some point Corsair has decided to shove iCUE down our throat with their product I would suggest unless you are going all Corsair just get some great RAM by G.Skill and save yourself a load of headaches. 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...