Jump to content
Corsair Community

Unknown Device after iCue update


SP77
 Share

Recommended Posts

Hello everyone. For some reason after updating iCue to the latest version (3.34.170), I now see unknown device under "other devices". I've tried suggestions I've found in other posts but none worked. Uninstalled, unplugged, swapped USB header. Rebooted and shutdown. Disabled device in Device Manager and uninstalled it. Nada. The only Corsair device I have installed is an H80i v2. Seems to be working normally, the only difference is now it makes the connected/disconnected sound when iCue starts. It might be conflicting with my Dualshock controller though, because now when I'm gaming it temporarily stops responding. I don't have any RGB fans, so no lights malfunctioning but the fans that are installed are spinning as usual. And my Logitech wireless keyboard and mouse are working without issue too. So are the cases USB front panel slots. When I look in the properties of the unknown device, under events it tells me that the issue began occurring on 11/5 which was when I updated iCue.

 

-11/5/2020 3:39:24pm Device deleted

-11/5/2020 3:39:27pm Device configured (null)

 

Earlier in the week I had connected a second monitor and was looking in device manager to make sure all was well with that and this issue wasn't present.

 

 

Hopefully, someone has some help or advice to put my anal mind at ease. Take care all and stay Corona free.

Link to comment
Share on other sites

 Share

×
×
  • Create New...