Jump to content
Corsair Community

How to remove duplicate devices help


Penfoldius
 Share

Recommended Posts

I recently have started using my K63 Wireless keyboard and my Dark Core SE mouse again to for wireless gaming from my couch. I have for some reason Dark Core SE and Dark Core SE (1) showing in devices. The duplicate mouse isn't being used and has a yellow error triangle saying not connected

 

https://imgur.com/NhaVCAF

 

I have tried using the unchecking show only connected devices, but the mouse still shows afterwards.

 

Is there something I have not tried or is there anything I can do to remove it as It isn't the mouse i use as the "Dark Core SE" is my default mouse which i use both whilst wired and wirelessly.

 

Thanks in advance

Link to comment
Share on other sites

Hey Penfoldius. I was having the same issue with my h80i v2. It was crazy irritating that I couldn't figure it out either. What ended up working for me was advice that I found in an old post after googling. If it's still listing two devices, in settings restart the service along with checking the option to show only connected devices. Click on the Dark Core SE or SE (1) on the iCue home screen, and afterward click on the icon in the upper right corner which changes the view from grid to text. In my case, it changes from a fan icon to H80i v2 text. Once you see the text, double click on that to edit it. I just added "CPU Cooler" to mine. So you could put something like Dark Core SE - RGB Mouse. Not sure why that worked but thankfully it did.

 

Hope it clears up for you. Now, I'm off to try to find a fix for a new issue (unknown device in device manager after iCue update).

Link to comment
Share on other sites

 Share

×
×
  • Create New...