Jump to content
Corsair Community

Keyboard Randomly stops working


hakang
 Share

Recommended Posts

Hi All,

I've K70 RGB MK2 keyboard (CH-9109014-TR) connected to the below system. Keyboard is pretty new (procured 3 months ago) and still in warranty period.

 

Assus-TUF GamingX-570 plus

MSI GEFORCE 2060 Super Ventus

Windows Home 10 32/64 Bit

 

Keyboard randomly stops working. When problem happens, keyboard lights works as expected but keyboard keys don't function at all. PC Reset or unplugging/plugging of the keyboard to USB ports resolves the issue.

All other PC functions work properly when keyboard doesn't work. Mouse is connected to keyboard and mouse also works properly when keyboard is not functioning.

I've tried changing different USB ports but problem still continue. I've removed and reinstalled the keyboard which didn't help.

 

ICUE software is at the latest version.

Keyboard firmware is at the latest version.

 

Please kindly share your feedbacks and possible solution actions around this annoying problem..

Link to comment
Share on other sites

  • Corsair Employees

Hi hakang,

 

Have you tried resetting the keyboard itself? To reset your keyboard:

 

  1. Unplug the keyboard.
  2. With the keyboard unplugged, hold down the ESC key.
  3. While holding down the ESC key, plug the keyboard back into the computer.
  4. Keep holding the ESC key until the keyboard begins to flash.
  5. Unplug the keyboard again, then plug it back in.

 

If the reset does not remedy your issue, I suggest contacting our support team by opening a ticket at https://help.corsair.com, they'll be able to help you out.

Link to comment
Share on other sites

Hi Albert,

 

Many thanks for your answer. I 've not tried this yet.

 

I know this reset steps but not tried since I was not sure if this reset will remediate the problem continuously or this action is mostly for a keyboard completely unresponsive.. In my case as mentioned, keyboard's lights are normal as expected when the problem happens but keys are not working... anyways I will try..

 

FYI, as another action item , I've removed ICUE yesterday evening and observing. Issue hasn't happened until now (hope it will not). If issue happens again, I will try your suggestion and write here the result Thanks again.

 

Regards,

Link to comment
Share on other sites

 Share

×
×
  • Create New...