Jump to content
Corsair Community

Corsair Void Pro sidetone not working after windows update. I've tried everything


ChiralLegioN
 Share

Recommended Posts

Hello! so i have ran into a problem with my Corsair Void Pro headset after a windows update. When i turn the headset on, firstly the red light indicating the mic is muted stays on when the boom is in both the up and down position. See, i have to have my sidetone as i have a small child and it help me to be more aware of my surrounding while im gaming. If i try to enable or disable the sidetone in the software, it does nothing. If i press the mute mic button (short press, not hold), instead of getting the mute notification, it instead says "Mic feedback on/off" without actually effecting the feedback and the mute button doesnt mute the mic at all.

 

I've tried soft resetting the headset by holding the mute for 15 seconds.

 

i've uninstalled both headset drivers and software and re-installed them.

 

i've tried rolling back the ICUE software but i have a hard time finding one to roll back thats older but not too old as the last time i rolled back it almost completely disabled the headset entirely.

 

I've tried the dongle in multiple different usb slots to no success as well.

 

I've uninstalled the drivers in device manager as well as deleted the registry entries in regedit.

 

if i plug the headset into another computer the problem doesn't exist so i know it's not a hardware issue.

 

Please if there is anything you can do to help i would gladly appreciate it.

 

(support ticket #2003680430

Link to comment
Share on other sites

Hi ChiralLegioN! I'm having the same problem. I've went and tried all of your steps already and I'm still unable to hear anything from my headset. iCUE isn't detecting them.

 

If you manage to sort the problem, please let me know.

 

I've also contacted support, no telling how long that'll take with what's going on in the world right now.

 

Appreciate the help! :)

 

ticket number is (2003692681).

Link to comment
Share on other sites

  • Corsair Employees

This behavior should have been resolved in the latest iCUE release of 3.34.161 and 3.34.170. Can you confirm which version of iCUE is installed on your system currently? If you're not sure, you can download the latest version through the following link:

 

https://downloads.corsair.com/Files/CUE/iCUESetup_3.34.170_release.msi

Link to comment
Share on other sites

 Share

×
×
  • Create New...