Jump to content
Corsair Community

Corsair RGB hub


Nigawolf
 Share

Recommended Posts

Hi guys,

 

I've got a Corsair Crystal 570X case which comes with the Corsair RGB Hub. I've plugged into it 5x120LL and 1x120SP that comes with it.

 

The issue is only 2x120LL of the fans start up when I turn my PC on. If I press the 3 buttons on top of the case for changing the RGB settings of the fans, I might get lucky and turn the 3rd 120LL fan on. In 1 out of 100 of the times, the other 2 120LL fans turn on as well. If not, just a total of 2 actually turn on.

 

What I've found out is that the fans on pos. 4, 5 and 6 on the Corsair RGB hub just refuse to work. I've tested so many combinations to see if there is a way to make it work but it just doesn't. Is getting the Corsair Commander Pro the only solution to this?

 

Any help will be greatly appreciated.

Link to comment
Share on other sites

I am not sure the SP-RGB is going work with the LL at all. Is that in the middle of the sequence? Or at the end?

 

With the SP-fan removed, test the LL. If fans after slot 3 don't work, but those same fans do work when moved to slots 1-2, then you probably have a bad RGB Lighting Hub. Contact Corsair Support so they can send you a new one. That is the device that provides the lighting current for the fans, so getting the Commander won't help. It needs the RGB Lighting Hub too. The Commander is necessary if you want fan speed control from within CUE.

  • Confused 1
Link to comment
Share on other sites

  • Corsair Employees

Hey,

 

The SP120 and LL120 will not work properly when used on the same RGB Hub. Did you happen to get the 3 pack of LL120? It would have come with a Lighting Node Pro, and an RGB Hub, the case also came with an RGB Hub. You would place each LL120 on one hub, and the SP120 on the other hub, then connect the hubs to the 2 lighting channels on the Lighting Node Pro. Would then control the Lighting Node Pro via software using iCUE. If you didn't get the 3 pack of LL120, I would consider returning 3 LL120 and getting the 3-Pack to get the Lighting Node Pro.

 

Let me know if you have any further questions.

Link to comment
Share on other sites

Hey,

 

The SP120 and LL120 will not work properly when used on the same RGB Hub. Did you happen to get the 3 pack of LL120? It would have come with a Lighting Node Pro, and an RGB Hub, the case also came with an RGB Hub. You would place each LL120 on one hub, and the SP120 on the other hub, then connect the hubs to the 2 lighting channels on the Lighting Node Pro. Would then control the Lighting Node Pro via software using iCUE. If you didn't get the 3 pack of LL120, I would consider returning 3 LL120 and getting the 3-Pack to get the Lighting Node Pro.

 

Let me know if you have any further questions.

 

In that case, since I have 5x 120LL fans, if i plug them in the RGB hub they should all work, correct? Because they dont :(:. Also yeah, i just got the 3x fans without anything else because i thought since i have the Hub with the case i wouldn't need anything else.

Link to comment
Share on other sites

If I press the 3 buttons on top of the case....

 

There's the problem. That case controller is for the SP-RGB fans that came with the case. It won't work with other fan types. As mentioned, you need a lighting controller for the LL fans (Lighting Node Pro, Commander Pro) and those need to be controlled through the CUE software.

Link to comment
Share on other sites

  • 3 weeks later...
I have just purchased the Corsair Crystal X570 RED case. I also purchased an addtional SP120 RGB fan for the rear of the case. FIRST ISSUE. The HUB is not recognized by iCUE. SECOND ISSUE. ALL four fans spin up, only THREE on the front change color and the REAR fan (the addtional SP120 ONLY lights as WHITE). Any suggestions or comments are welcome. I am using a GIGABYTE AORUS X570 MASTER mb. Edited by WifiWizard
Link to comment
Share on other sites

 Share

×
×
  • Create New...