Jump to content
Corsair Community

Strafe MK2 doesn't work with BIOS or Bitlocker


Trigeminal
 Share

Recommended Posts

Hey all,

 

Looking a little help regarding the Strafe MK2 keyboard. I absolutely love how quiet the keyboard and did not love the sounds of my other keyboard during conference calls or late at night. I have a few small things I am still trying to figure out with the iCue software but have one huge issue currently:

 

When resetting my computer, the Strafe MK2 doesn't work with BIOS or Bitlocker. It seems anything I type is not the same thing that appears on the screen. The "backspace" and "enter" key type things instead of performing their respective functions. This basically requires me to keep my old keyboard around just to boot into windows.

 

In searching the web, I discovered that holding the "Lock" and "F1" key together for ~3 seconds would enter bios compatibility mode. I have tried that and it does appear to enter an alternate mode with the scroll lock button flashing, but it still doesn't type like it should.

 

Any advice on what to do???

 

I am worried if I can't solve this, I'll need to return the keyboard, as this is a non-functional situation. I really don't want to do that.

 

Thanks for your help.

Link to comment
Share on other sites

  • Corsair Employees

Hi Trigeminal,

 

That Winlock + F1 for ~5 seconds to get the flashing Scroll Lock is definitely how you toggle BIOS mode for that keyboard, which should give you the namesake ability of using the keyboard in BIOS, you are correct.

 

Try enabling it in Windows specifically before rebooting and attempting to enter / utilize BIOS.

 

If that doesn't help, please open a ticket with support for some further assistance on this issue.

Link to comment
Share on other sites

  • 2 weeks later...
 Share

×
×
  • Create New...