Jump to content
Corsair Community

Virtuoso won't pair.


Corky3D
 Share

Recommended Posts

Hello everybody, I have a constant problem with my Corsair Virtuoso. 70% of the time it won't pair. I've done the thing about plugging it in for 15 minutes nothing changes. Only time I can get it to pair is if I restart the computer.

 

I've only had the headset for about 20 days, greatest headset i've had, except for the constant pair issues. I've emailed Corsair and got no response. If I can't get help here, I think i'll refund it and go back to Logitech. I love this headset, but I've never had this many problems with something, then pay decent money for it and never get a response from the company that made it. I sent them a support email over 10 days ago.

 

Headset will work perfectly, put the computer to sleep go out to the garage for a few hours then bam, won't connect. Sometimes it shows unavailable other it won't show it's even being recognized in ICUE. 10 minutes ago it was working perfectly, paused a video on Youtube, went to a different website. Came back to Youtube 2 minutes later, didn't change anything. Start the video, no sound. Go to ICUE, acts like I pulled the USB. Sometimes it will be recognized when the USB cable is plugged in, other times it won't.

Edited by Corky3D
Link to comment
Share on other sites

  • Corsair Employees
Try disabling USB selective suspend in your Windows Advanced Power Settings. If you have the dongle plugged into a USB hub or KVM, try moving the connection to the motherboard on different USB ports. Also make sure you have the latest firmware update installed under settings in iCUE.
Link to comment
Share on other sites

  • 4 weeks later...
Try disabling USB selective suspend in your Windows Advanced Power Settings. If you have the dongle plugged into a USB hub or KVM, try moving the connection to the motherboard on different USB ports. Also make sure you have the latest firmware update installed under settings in iCUE.

 

That fixed 50% of the problem. It made it work a lot better, but I still have it unpair 2-3 times a day and only way to re-pair is to restart the computer. Everything is updated. I even uninstalled it, then reinstalled iCue. I have had no problems of it pairing when I put the computer to sleep now. The only problem is it unpairs then won't pair again, unless I do a restart.

 

It will unpair it's self randomly. Sometimes it will unpair if i pull the microphone out. Other times i'll be watching a Youtube video, then all the sudden it unpairs it's self.

Edited by Corky3D
Link to comment
Share on other sites

You don't have to reply, I'm done with Corsair. Back to Logitech. I can't get any help over phone or anything. Corsair is the worst customer service I have encountered in my life. I sat on hold for 1 hour and 45 minutes.

 

I am refunding the headset Monday.

Link to comment
Share on other sites

 Share

×
×
  • Create New...