Jump to content
  • Gaming Gear
  • Streaming Gear
  • PC Components
  • Gaming PCs
  • Software
  • Community
  • Support
  • Gaming Gear
  • Keyboards
  • Headsets
  • Mice
  • Mousepads
  • Chairs
  • Apparel | Gear
  • Accessories
  • Ambient Lighting
  • Streaming Gear
  • Capture
  • Stream Deck
  • Audio
  • Lighting
  • Green Screen
  • Multi Mount
  • PC Components
  • Cases
  • CPU Coolers
  • Fans
  • Memory
  • Power Supply Units
  • Custom Cooling
  • Storage
  • Thunderbolt Docks
  • Gaming PCs
  • CORSAIR ONE Gaming PCs
  • CORSAIR ONE Workstation Grade PCs
  • VENGEANCE Gaming PCs
  • iCUE Certified Gaming PCs
  • Visit Origin PC
  • Software
  • Download Software
  • iCUE Software
  • iCUE for macOS
  • Community
  • CORSAIR Gaming
  • Esports
  • Streamers
  • Students
  • Forum
  • Blog
  • Wallpapers
  • Press Room
  • Support
  • Download Software
  • Customer Support
  • FAQs
  • Warranty
  • Keyboards
  • All Keyboards
  • RGB Mechanical Gaming Keyboards
  • Wireless Keyboards
  • Headsets
  • All Headsets
  • Wireless Headsets
  • USB & Stereo Headsets
  • Mice
  • All Mice
  • Wireless Mice
  • Wired Mice
  • Cases
  • All Cases
  • iCUE Smart Cases
  • Mid-tower Cases
  • Full-tower Cases
  • Small Form Factor Cases
  • Power Supply Units
  • All Power Supply Units
  • iCUE-controlled PSUs
  • Premium Efficiency PSUs
  • CPU Coolers
  • CPU Coolers
  • iCUE Smart Coolers
  • 240mm AiO Coolers
  • 280mm AiO Coolers
  • CPU Air Coolers
  • Custom Cooling
  • All Liquid Cooling
  • All Hydro X Products
  • Design Your Loop
  • Fans
  • All Fans
  • RGB Fans
  • 120mm Fans
  • 140mm Fans
  • Storage
  • All Storage
  • M.2 SSDs
  • USB Flash Drives
  • Memory
  • All Memory
  • Performance RGB Memory
  • Performance Memory
  • Memory Finder
  • Thunderbolt Docks
  • All Thunderbolt Docks
  • Accessories
Corsair Community

H100I Platinum SE Cooling Block not working


Jerfburg
 Share

Recommended Posts

Hey there guys i recently just started building my second PC and am having trouble with the cooling block over my CPU. The radiator fans are working and the RGB is going but the block on the other hand is not. I've searched online and am sure i have them plugged in the right spots. Any help would be great.

Thanks in Advance

PC2.thumb.jpeg.6f91e5a51c3a6b4b14d5e5c14b340a55.jpeg

PC1.thumb.jpeg.951288f6cba025cf44631988ab1bc4de.jpeg

Link to comment
Share on other sites

 Share

×
×
  • Create New...