Jump to content
Corsair Community

Issues with Corsair 650W 80 Plus White VS650


Ellywan
 Share

Recommended Posts

Hello everyone, first post here.

 

I have recently bought a new computer(piece by piece) and a Corsair 650W 80 from an official seller.

 

The power supply worked for about 1 hour or so, there was time enough to install windows 10, configure with basic setup and when i was downloading the GPU Driver, boom! just turn off, it won't turn in again, although the Motherboard and the GPU lights are still on.

 

i've tested my old power supply and it worked.

 

Is it burned? Should proceed with the warranty or am i doing something wrong?

 

My setup:

 

GeForce GTX 1660 SUPER, 14.0 Gbps, 6GB, GDDR6

Intel Core i5-9400F Coffee Lake, Cache 9MB, 2.9GHz

2x Memory HyperX Fury, 8GB, 2666MHz, DDR4

Motherboard Asrock B365M Phantom Gaming 4, Intel LGA 1151, mATX, DDR4

Edited by Ellywan
Link to comment
Share on other sites

  • Corsair Employees
Hello everyone, first post here.

 

I have recently bought a new computer(piece by piece) and a Corsair 650W 80 from an official seller.

 

The power supply worked for about 1 hour or so, there was time enough to install windows 10, configure with basic setup and when i was downloading the GPU Driver, boom! just turn off, it won't turn in again, although the Motherboard and the GPU lights are still on.

 

i've tested my old power supply and it worked.

 

Is it burned? Should proceed with the warranty or am i doing something wrong?

 

My setup:

 

GeForce GTX 1660 SUPER, 14.0 Gbps, 6GB, GDDR6

Intel Core i5-9400F Coffee Lake, Cache 9MB, 2.9GHz

2x Memory HyperX Fury, 8GB, 2666MHz, DDR4

Motherboard Asrock B365M Phantom Gaming 4, Intel LGA 1151, mATX, DDR4

 

Warranty time.

Link to comment
Share on other sites

 Share

×
×
  • Create New...