Jump to content
Corsair Community

iCue software update - 3.34.161 (Now Available)


Jcorsai2020
 Share

Recommended Posts

My Commander Pro and Headset not even detected. Trying to restart the Corsair service through ICUE and it gives warning that it is not able to restart.

 

UPDATE: Ran a repair on the update that got installed and now all devices are showing up in ICUE.

Edited by StormySeaDog
Link to comment
Share on other sites

Still doesn't fix the actual critical issue introduced around May with Windows 10 Update 2004 that causes a combination of LL fans and H100i RGB pumps to flicker, or simply not light up at all. In many cases they light up in totally different colors not set in the profiles.

I don't mean to sound arrogant, but I'm a programmer dealing a lot with optimization and debugging. It would literally have been faster for them to hire me and actually get this fixed than just pushing out clueless patches.

 

Corsair, what are you doing ??

Link to comment
Share on other sites

Update failed (PC frozen) during the install, had to restart the whole PC and download the .msi package.

Install was sucessfull but no any response from the ICue icon in the taskbar or from the software itself. I can click on the taskbar icon how many times I will - nothing happend, software doesn't show up, context menu doesn't appear. According to taskmanager the software is running.

 

Just downgraded to 3.32.80 - everthing back to normal.

 

Very good job.

Link to comment
Share on other sites

This update killed my pc. After the restart my speakers sound vanished. Another restart later the windows system was unable to load / boot. Had to recover my PC via Veeam Agent software. So my advice: update only, if your backup software is working and up to date.
Link to comment
Share on other sites

First Post here, before I only have read through the forums...

The issue for my iCue installation for some time now is the same also with this version, and also it seems nobody at all is having any interest at all to fix that issue once and for ever.

CPU Usage from corsair.service is between 12% and 14% PERMANENTLY.

Which is almost 90% of one core of a 3900X when setting the affinity to one core.

It is a shame that this issue is not fixed for so long.

Link to comment
Share on other sites

Just received a notification that a software update was available for iCue. Googling wasn't able to find any patch notes for this release.

 

Any idea on when those get posted? Trying to decide if it's worth it to upgrade right now.

 

My equalizer was not working and my 7.1 either, with the update all the problems were fixed. (I have a Void PRO RGB USB)

 

edit: My drivers stop working too and I had to restart my PC, but all my problems of months are working real fine.

Link to comment
Share on other sites

This is the second release version in a row that I've had to uninstall and revert back to 3.32.80 so I can actually use iCue. Mouse binds not working and then profiles not working.

 

Pretty basic stuff. What exactly does the QA team do at Corsair? Do you even have a QA team?

 

Oh ... and still no patch notes for 3.34.161.

Edited by Neux
Link to comment
Share on other sites

Does this fix the issue that occurred in version 3.33.246 where, if you had several keys bound to the mouse, that the first one would stop as soon as a second one was being pressed? Just saw Neux' reply, I'll stay on 3.32.80 for now. Thanks for the info! Edited by LizDeLaFuentez
Didn't realise the post above was talking about my issue.
Link to comment
Share on other sites

This update like all the other versions before it, continues to BSOD my computer after a seemly random amount of time (last time it took 4 hours). To "stabilize" it, I've used the old trick and removed the CpuId files from the "C:\Program Files (x86)\Corsair\CORSAIR iCUE Software" directory (there are 10 different files now):

 

Corsair.Module.CpuId.dll

Corsair.Module.CpuIdDevice.dll

Corsair.Service.CpuIdRemote.exe

Corsair.Service.CpuIdRemote.exe.config

Corsair.Service.CpuIdRemote64.exe

Corsair.Service.CpuIdRemote64.exe.config

cpuidsdk.dll

cpuidsdk64.dll

CpuIdWrapper.dll

CpuIdWrapper64.dll

 

I've been running a full day with no crashes, but of course...no system monitoring. This was a real shame as I'm re-building my computer and was hoping to replace my old 3+ year old H60 with a new H115i or H150i CPU cooler. But since I won't be able to use iCUE to control the fans, I've ordered a competitor's AIO that works with the motherboard PWM headers instead.

 

If anyone from Corsair is reading this, the CpuId BSOD bug is losing you sales. I want to buy more Corsair products, but avoid adding any more iCUE-dependant devices for fear of destabilizing my PC (I only use iCUE to support a K70 RGB MK.2 Low Profile keyboard...which is superior hardware imho).

 

The last thread below may indicate a possible solution of using "industry standard synchronization mutexes". Not sure what that is, but it might be a clue.

 

Corsair iCUE software causing PC crashes

 

Black Screening / Video Card output switching off from iCUE

https://forum.corsair.com/v3/showthread.php?t=177867&page=8

 

New Computer Crashing To Black Screen Have To Turn Off Power Supply To Restart

https://forums.tomshardware.com/threads/new-computer-crashing-to-black-screen-have-to-turn-off-power-supply-to-restart.3372871/

 

Corsair iCUE program breaks after enabling sensors in AIDA64

https://forums.aida64.com/topic/5208-corsair-icue-program-breaks-after-enabling-sensors-in-aida64/

Link to comment
Share on other sites

update was scary... lol

 

the lighting node core wasn't recognized after updating. had to do a repair to make it work. had i not been on this site, i wouldn't have known what to do. that can't be a good thing... i feel sorry for non techie people who like RGB.

Link to comment
Share on other sites

I had issue with this update as well. Trying to upgrade would cause my PC to freeze at login and I lost ALL USB devices once it hit Windows. I had to boot and system restore. Then I uninstalled completely, then installed this version and that worked (kind of).

 

Now, like others, it runs in the background (supposedly) but the taskbar icon and software do not, it just crashes repeatedly.

 

Here's my event viewer showing the crash:

ObD7nQs

Link to comment
Share on other sites

This update like all the other versions before it, continues to BSOD my computer after a seemly random amount of time

 

This. Still. Happens!? :wtfeh:

 

Did you ever have Riot Vanguard installed on your system?

 

(Just asking out of curiosity because iCUE kept on causing BSOD for me too even on a previously stable 3.12 version that I've been using for months; which was "mitigated" by deleting the CpuId files like everyone else did... but this only started happening on my end after installing AND uninstalling Vanguard.)

Link to comment
Share on other sites

 Share

×
×
  • Create New...