Jump to content
Corsair Community

H100i RGB Pro XT issue?


h0ray
 Share

Recommended Posts

I've always set my iCUE to Spiral Rainbow. I've got RAM and 3 Fans and the AIO going. But I noticed recently - the CPU cooler isn't doing rainbow colors. I just see mostly orange and read. If I restart it would work but then it'll go back to that issue. I updated the AIO firmware. Still the same. If I do instant lighting and chose white - it would sometimes work.. sometimes it show red-ish/orange-ish.

 

Only built this PC in March. Is it already dying?

Link to comment
Share on other sites

@h0ray: You are not alone. I've had this AIO as well for a few months now, and I can confirm that it has its feed of issues (which can be scary when they're encountered, as they can cause system instability).

 

The first time the AIO died on me, the fans ramped up to 100% and wouldn't stop no matter what I did. After restarting, the fans spun down to the point where heat would easily BSOD the system. The only thing that could fix it was by getting lucky and forcing a firmware update.

 

And now, over the past day or two (the reason why I'm here), the fans were powering down again, and the LEDs were glitching up and not functioning properly. I tried the force firmware update fix, but even that was bricked and stuck on the updating bar. Even the BIOS didn't detect the fan and threw me an error. I had to do a clean shut down and restart and reinstall the firmware just for it to be fixed again.

 

Corsair really needs to make their coolers have an 'offline' backup where it flashes a copy of the preset you made in iCUE to the AIO itself as a backup in case something goes terribly wrong and it loses communication with the system. Kind of like gaming mice which can store presets and not have to rely on the PC.

Link to comment
Share on other sites

 Share

×
×
  • Create New...