Jump to content
Corsair Community

Adding Windows Apps such as Spotify, Xbox app, etc

Recommended Posts

Adding buttons to start apps located in the AppData folder simply does not work for me.

I get "The File cannot be accessed by the system" when trying to select the application to launch every time. This issue is present on ALL apps located under AppData.

Most of the apps I am trying to add are ones I REALLY wanted to add to the Nexus, such as Spotify, the Xbox PC App, Discord,...

I am logged in as admin (only account on pc), I have full control/permissions, tried making a shortcut (and placing that in various locations),...

Am I missing something here?

Link to comment
Share on other sites

  • Corsair Employees

Hi PJ_Berri,


I tested this out and ran into what you did -- the problem is more with the Discord shortcut pointing to that update.exe here (and is a similar situation with these other apps). Switch the application to launch manually to this and it will work, I confirm as I *just* tested this for you

Edited by Corsair Blade
Link to comment
Share on other sites

Alright, thanks for that.

Discord works just fine now indeed, but can you please try this with the Xbox app? Not the Xbox game bar or console companion, but the Xbox game pass app.

I can't get it to add to Nexus, no matter what I try.

In the AppData folder there is only a shortcut to be found, so that must be the problem. I believe the actual install location is in Program Files/WindowsApps but that folder is owned by TrustedInstaller, and I DO NOT want to manually change ownership. I tried doing that last year because of a similar problem, but doing that messed up my whole pc. It broke the microsoft store and its apps for me, and I ended up having to do a clean Windows install to get everything working again.

I realize the problem probably lies more with Windows then it does with the Nexus app, but it would be great if there was some way around this.

Edited by PJ_Berri
Link to comment
Share on other sites

  • 4 weeks later...

Indeed, I have tried various things but the Xbox App just won't work. I realise the problem probably lies more in the way the app is set up,but still, it's a bummer. Maybe you folks could contact Microsoft or the people behind the Xbox App to work out some sort of solution?

Having an entire screen on the Nexus dedicated to Xbox Gaming would be pretty sweet, just imagine... a shortcut to the app, social menu, capture menu, etc. Would also serve as some cool marketing material, "iCue Nexus, now with Xbox integration" ;p

Link to comment
Share on other sites

  • 5 months later...

To start the Xbox app, execute the following from a batch file


"explorer.exe shell:appsFolder\Microsoft.GamingApp_8wekyb3d8bbwe!Microsoft.Xbox.App"


To start Spotify you can get away with running "start Spotify:" from a batch file


same for Netflix, "start Netflix:"


The windows weather app "explorer.exe shell:appsFolder\Microsoft.BingWeather_8wekyb3d8bbwe!App"


Flight Sim "explorer.exe shell:appsFolder\Microsoft.FlightSimulator_8wekyb3d8bbwe!App"


Ookla speedtest "explorer.exe shell:appsFolder\Ookla.SpeedtestbyOokla_43tkc6nmykmb6!App"


Will try and get around to writing a guide to identify the different ways to start MS Store apps

  • Confused 2
Link to comment
Share on other sites

  • 1 month later...

So thanks to Gumby I was able to find exactly what I needed to get to the apps I needed.


Basically, I ran the command:




In the Windows Run (Win+R) box


That opened a new folder that contained all the apps. From there, I was able to create a shortcut to the desktop for the apps I wanted to launch. I then created a batch file containing the command as Gumby posted but specifically for my apps.


(e.g. Youtube Music was "explorer.exe shell:appsFolder\music.youtube.com-9F558962_vezhnr0wkvrcy!App")


This should let you find the identifier for any app listed in the folder and hopefully that allows you to run what you need.


Maybe the team at Corsair will add support to launch apps in the future but this is how I'm going to do it for now.

Link to comment
Share on other sites

  • 1 year later...
  • 1 month later...
  • 1 month later...

I just created the app shortcut to my desktop. Then went into the properties and assigned a keyboard shortcut to launch that app. in the Nexus, I  ran a macro with that keyboard command. Works fine!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...